summaryrefslogtreecommitdiffstats
path: root/package/liboauth
diff options
context:
space:
mode:
authorWill Newton <will.newton@gmail.com>2012-02-02 11:28:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-02-02 12:48:39 +0100
commitcee43cbcbd698f95025ecf3fe0697ecedf5f4aab (patch)
treeb549e18e3af67d1b98d3aa24ea77da871012c3f8 /package/liboauth
parent5256c77b46fb2fd9bf84dd790a7b8de873b7dcd9 (diff)
downloadbuildroot-novena-cee43cbcbd698f95025ecf3fe0697ecedf5f4aab.tar.gz
buildroot-novena-cee43cbcbd698f95025ecf3fe0697ecedf5f4aab.zip
liboauth: Add new package
[Peter: swap libcurl test around] Signed-off-by: Will Newton <will.newton@imgtec.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/liboauth')
-rw-r--r--package/liboauth/Config.in10
-rw-r--r--package/liboauth/liboauth.mk19
2 files changed, 29 insertions, 0 deletions
diff --git a/package/liboauth/Config.in b/package/liboauth/Config.in
new file mode 100644
index 000000000..77a78f115
--- /dev/null
+++ b/package/liboauth/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LIBOAUTH
+ bool "liboauth"
+ select BR2_PACKAGE_OPENSSL
+ help
+ liboauth is a collection of c functions implementing the oAuth
+ Core 1.0 Rev A standard API. liboauth provides basic functions to
+ escape and encode parameters according to oAuth specs and offers
+ high-level functions to sign requests or verify signatures.
+
+ http://liboauth.sourceforge.net/
diff --git a/package/liboauth/liboauth.mk b/package/liboauth/liboauth.mk
new file mode 100644
index 000000000..864694791
--- /dev/null
+++ b/package/liboauth/liboauth.mk
@@ -0,0 +1,19 @@
+#############################################################
+#
+# liboauth
+#
+#############################################################
+LIBOAUTH_VERSION = 0.9.6
+LIBOAUTH_SOURCE = liboauth-$(LIBOAUTH_VERSION).tar.gz
+LIBOAUTH_SITE = http://liboauth.sourceforge.net/pool
+LIBOAUTH_INSTALL_STAGING = YES
+
+LIBOAUTH_DEPENDENCIES += host-pkg-config openssl
+
+ifeq ($(BR2_PACKAGE_LIBCURL),y)
+LIBOAUTH_DEPENDENCIES += libcurl
+else
+LIBOAUTH_CONF_OPT += --disable-libcurl
+endif
+
+$(eval $(call AUTOTARGETS))