summaryrefslogtreecommitdiffstats
path: root/package/libnl
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-05-16 11:18:26 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-16 22:54:37 +0200
commitf890debb30c0ce920bc44e7d74f1d5d4280d4625 (patch)
tree7acc211c9f04b848051ce5868488964cc79eabbe /package/libnl
parenta7e78f974e4536c23904cb5714ce1a917b3f420e (diff)
downloadbuildroot-novena-f890debb30c0ce920bc44e7d74f1d5d4280d4625.tar.gz
buildroot-novena-f890debb30c0ce920bc44e7d74f1d5d4280d4625.zip
libnl: minor package fixes
* libnl fails to build with multiple jobs so keep make at -j1 * Multiple libraries are installed so update uninstall target for this [Peter: remove libnl/libnl-*.* to catch subdir + any new libs in the future] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libnl')
-rw-r--r--package/libnl/libnl.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libnl/libnl.mk b/package/libnl/libnl.mk
index 8d3b9ade7..6edb1f8e5 100644
--- a/package/libnl/libnl.mk
+++ b/package/libnl/libnl.mk
@@ -9,9 +9,11 @@ LIBNL_SOURCE = libnl-$(LIBNL_VERSION).tar.gz
LIBNL_SITE = http://www.infradead.org/~tgr/libnl/files/
LIBNL_INSTALL_STAGING = YES
LIBNL_DEPENDENCIES = host-bison
+LIBNL_MAKE = $(MAKE1)
define LIBNL_UNINSTALL_TARGET_CMDS
- rm -f $(TARGET_DIR)/usr/lib/libnl.so*
+ rm -r $(TARGET_DIR)/usr/lib/libnl.* $(TARGET_DIR)/usr/lib/libnl-*.*
+ rm -rf $(TARGET_DIR)/usr/lib/libnl
endef
$(eval $(call AUTOTARGETS,package,libnl))