summaryrefslogtreecommitdiffstats
path: root/package/libnl
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-05-14 02:29:58 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-14 21:37:06 +0200
commit4b55a9952014b37ce565b46ee6e93018555127fa (patch)
tree5cf33d04cb9fe7b8e36c66440e4aa9fbc66c142e /package/libnl
parent9f7bf3b63d820616fe8ce2f3fa485c22542f2acb (diff)
downloadbuildroot-novena-4b55a9952014b37ce565b46ee6e93018555127fa.tar.gz
buildroot-novena-4b55a9952014b37ce565b46ee6e93018555127fa.zip
libnl: bump to version 3.2.9 and enhance
Bump to version 3.2.9 and add an option to install the tools. Since they're not usually required we default to N to reduce size. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libnl')
-rw-r--r--package/libnl/Config.in6
-rw-r--r--package/libnl/libnl.mk13
2 files changed, 18 insertions, 1 deletions
diff --git a/package/libnl/Config.in b/package/libnl/Config.in
index 24e481361..c7d435983 100644
--- a/package/libnl/Config.in
+++ b/package/libnl/Config.in
@@ -4,3 +4,9 @@ config BR2_PACKAGE_LIBNL
A library for applications dealing with netlink socket.
http://people.suug.ch/~tgr/libnl/
+
+config BR2_PACKAGE_LIBNL_TOOLS
+ bool "install tools"
+ depends on BR2_PACKAGE_LIBNL
+ help
+ Install binary tools.
diff --git a/package/libnl/libnl.mk b/package/libnl/libnl.mk
index 40aaf388e..a72370166 100644
--- a/package/libnl/libnl.mk
+++ b/package/libnl/libnl.mk
@@ -4,15 +4,26 @@
#
#############################################################
-LIBNL_VERSION = 3.2.8
+LIBNL_VERSION = 3.2.9
LIBNL_SITE = http://www.infradead.org/~tgr/libnl/files
LIBNL_INSTALL_STAGING = YES
LIBNL_DEPENDENCIES = host-bison
LIBNL_MAKE = $(MAKE1)
+LIBNL_BINARIES = class-add class-delete class-list classid-lookup cls-add \
+ cls-delete cls-list link-list pktloc-lookup qdisc-add qdisc-delete \
+ qdisc-list
define LIBNL_UNINSTALL_TARGET_CMDS
rm -r $(TARGET_DIR)/usr/lib/libnl.* $(TARGET_DIR)/usr/lib/libnl-*.*
rm -rf $(TARGET_DIR)/usr/lib/libnl
endef
+define LIBNL_REMOVE_TOOLS
+ rm -rf $(addprefix $(TARGET_DIR)/usr/sbin/nl-, $(LIBNL_BINARIES))
+endef
+
+ifneq ($(BR2_PACKAGE_LIBNL_TOOLS),y)
+LIBNL_POST_INSTALL_TARGET_HOOKS += LIBNL_REMOVE_TOOLS
+endif
+
$(eval $(call AUTOTARGETS))