summaryrefslogtreecommitdiffstats
path: root/package/libmad
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-11-27 21:40:57 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-11-27 21:40:57 +0000
commitfdca6a927068082f44acf1feef85060bee51096e (patch)
tree5abeadec600bc88cdd677b68b5857f708ede16ca /package/libmad
parentaef5bbb6652479d771efce7c320655898f365b3f (diff)
downloadbuildroot-novena-fdca6a927068082f44acf1feef85060bee51096e.tar.gz
buildroot-novena-fdca6a927068082f44acf1feef85060bee51096e.zip
Fix libmad configure order according to issue 0001571, revert old fix
Diffstat (limited to 'package/libmad')
-rw-r--r--package/libmad/libmad-0.15.1b-optimization.patch.avr3262
-rw-r--r--package/libmad/libmad.mk5
2 files changed, 31 insertions, 36 deletions
diff --git a/package/libmad/libmad-0.15.1b-optimization.patch.avr32 b/package/libmad/libmad-0.15.1b-optimization.patch.avr32
index f6620f591..b74eea322 100644
--- a/package/libmad/libmad-0.15.1b-optimization.patch.avr32
+++ b/package/libmad/libmad-0.15.1b-optimization.patch.avr32
@@ -139,20 +139,19 @@ index 5a51570..70f550a 100644
unsigned short mad_bit_crc(struct mad_bitptr, unsigned int, unsigned short);
# endif
-diff --git a/configure b/configure
-index ee421cc..7a9f0c8 100755
---- a/configure
-+++ b/configure
-@@ -1048,7 +1048,7 @@ Optional Features:
- --enable-speed optimize for speed over accuracy
- --enable-accuracy optimize for accuracy over speed
- --enable-fpm=ARCH use ARCH-specific fixed-point math routines (one of:
-- intel, arm, mips, sparc, ppc, 64bit, default)
-+ intel, arm, avr32, mips, sparc, ppc, 64bit, default)
- --enable-sso use subband synthesis optimization
- --disable-aso disable architecture-specific optimizations
- --enable-strict-iso use strict ISO/IEC interpretations
-@@ -21477,6 +21477,7 @@ if test "${enable_fpm+set}" = set; then
+diff --git a/configure.ac b/configure.ac
+index 9b79399..063cb9b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,13 +274,14 @@ fi
+ AC_MSG_CHECKING(for architecture-specific fixed-point math routines)
+ AC_ARG_ENABLE(fpm, AC_HELP_STRING([--enable-fpm=ARCH],
+ [use ARCH-specific fixed-point math routines
+- (one of: intel, arm, mips, sparc, ppc, 64bit, default)]),
++ (one of: intel, arm, avr32, mips, sparc, ppc, 64bit, default)]),
+ [
+ case "$enableval" in
+ yes) ;;
no|default|approx) FPM="DEFAULT" ;;
intel|i?86) FPM="INTEL" ;;
arm) FPM="ARM" ;;
@@ -160,7 +159,7 @@ index ee421cc..7a9f0c8 100755
mips) FPM="MIPS" ;;
sparc) FPM="SPARC" ;;
ppc|powerpc) FPM="PPC" ;;
-@@ -21498,6 +21499,7 @@ then
+@@ -298,6 +299,7 @@ then
case "$host" in
i?86-*) FPM="INTEL" ;;
arm*-*) FPM="ARM" ;;
@@ -168,7 +167,7 @@ index ee421cc..7a9f0c8 100755
mips*-*) FPM="MIPS" ;;
sparc*-*) FPM="SPARC" ;;
powerpc*-*) FPM="PPC" ;;
-@@ -21554,6 +21556,11 @@ then
+@@ -343,6 +345,11 @@ then
ASO="$ASO -DASO_IMDCT"
ASO_OBJS="imdct_l_arm.lo"
;;
@@ -180,19 +179,20 @@ index ee421cc..7a9f0c8 100755
mips*-*)
ASO="$ASO -DASO_INTERLEAVE2"
ASO="$ASO -DASO_ZEROCHECK"
-diff --git a/configure.ac b/configure.ac
-index 9b79399..063cb9b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -274,13 +274,14 @@ fi
- AC_MSG_CHECKING(for architecture-specific fixed-point math routines)
- AC_ARG_ENABLE(fpm, AC_HELP_STRING([--enable-fpm=ARCH],
- [use ARCH-specific fixed-point math routines
-- (one of: intel, arm, mips, sparc, ppc, 64bit, default)]),
-+ (one of: intel, arm, avr32, mips, sparc, ppc, 64bit, default)]),
- [
- case "$enableval" in
- yes) ;;
+diff --git a/configure b/configure
+index ee421cc..7a9f0c8 100755
+--- a/configure
++++ b/configure
+@@ -1048,7 +1048,7 @@ Optional Features:
+ --enable-speed optimize for speed over accuracy
+ --enable-accuracy optimize for accuracy over speed
+ --enable-fpm=ARCH use ARCH-specific fixed-point math routines (one of:
+- intel, arm, mips, sparc, ppc, 64bit, default)
++ intel, arm, avr32, mips, sparc, ppc, 64bit, default)
+ --enable-sso use subband synthesis optimization
+ --disable-aso disable architecture-specific optimizations
+ --enable-strict-iso use strict ISO/IEC interpretations
+@@ -21477,6 +21477,7 @@ if test "${enable_fpm+set}" = set; then
no|default|approx) FPM="DEFAULT" ;;
intel|i?86) FPM="INTEL" ;;
arm) FPM="ARM" ;;
@@ -200,7 +200,7 @@ index 9b79399..063cb9b 100644
mips) FPM="MIPS" ;;
sparc) FPM="SPARC" ;;
ppc|powerpc) FPM="PPC" ;;
-@@ -298,6 +299,7 @@ then
+@@ -21498,6 +21499,7 @@ then
case "$host" in
i?86-*) FPM="INTEL" ;;
arm*-*) FPM="ARM" ;;
@@ -208,7 +208,7 @@ index 9b79399..063cb9b 100644
mips*-*) FPM="MIPS" ;;
sparc*-*) FPM="SPARC" ;;
powerpc*-*) FPM="PPC" ;;
-@@ -343,6 +345,11 @@ then
+@@ -21554,6 +21556,11 @@ then
ASO="$ASO -DASO_IMDCT"
ASO_OBJS="imdct_l_arm.lo"
;;
diff --git a/package/libmad/libmad.mk b/package/libmad/libmad.mk
index 5eeab9881..7a2d98a8c 100644
--- a/package/libmad/libmad.mk
+++ b/package/libmad/libmad.mk
@@ -38,13 +38,8 @@ $(LIBMAD_DIR)/.configured: $(LIBMAD_DIR)/.unpacked
)
touch $@
-# This rule runs 'libtoolize' since the ltmain.sh which comes in the tarball
-# is unsuitable with new libtool versions (causing shared libraries to build
-# without the .so extension).
-
$(LIBMAD_DIR)/libmad.la: $(LIBMAD_DIR)/.configured
rm -f $@
- (cd $(LIBMAD_DIR); libtoolize --force)
$(MAKE) -C $(LIBMAD_DIR)
$(STAGING_DIR)/usr/lib/libmad.so.0: $(LIBMAD_DIR)/libmad.la