summaryrefslogtreecommitdiffstats
path: root/package/libjpeg
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-13 23:58:11 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-14 00:03:32 +0100
commit21dd3e777b5b9eb40c6e0fe9fadcf0c7fcc63901 (patch)
tree22cac2a11a428a7af3695554cf734f92f9d0f20a /package/libjpeg
parent39348d803bda0c0f33805b06d302669293e4d38a (diff)
downloadbuildroot-novena-21dd3e777b5b9eb40c6e0fe9fadcf0c7fcc63901.tar.gz
buildroot-novena-21dd3e777b5b9eb40c6e0fe9fadcf0c7fcc63901.zip
package: add selection between libjpeg and jpeg-turbo
Introduce a virtual 'jpeg' package, which pulls in either libjpeg or jpeg-turbo depending on a choice selection. Rename jpeg package to libjpeg so we can reuse 'jpeg' for the virtual package, making the change transparent to existing users and all the packages using libjpeg. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libjpeg')
-rw-r--r--package/libjpeg/libjpeg.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/libjpeg/libjpeg.mk b/package/libjpeg/libjpeg.mk
new file mode 100644
index 000000000..0df2b3a8b
--- /dev/null
+++ b/package/libjpeg/libjpeg.mk
@@ -0,0 +1,19 @@
+#############################################################
+#
+# libjpeg (libraries needed by some apps)
+#
+#############################################################
+
+LIBJPEG_VERSION = 8d
+LIBJPEG_SITE = http://www.ijg.org/files/
+LIBJPEG_SOURCE = jpegsrc.v$(LIBJPEG_VERSION).tar.gz
+LIBJPEG_INSTALL_STAGING = YES
+
+define LIBJPEG_REMOVE_USELESS_TOOLS
+ rm -f $(addprefix $(TARGET_DIR)/usr/bin/,cjpeg djpeg jpegtrans rdjpgcom wrjpgcom)
+endef
+
+LIBJPEG_POST_INSTALL_TARGET_HOOKS += LIBJPEG_REMOVE_USELESS_TOOLS
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))