summaryrefslogtreecommitdiffstats
path: root/package/libiqrf
diff options
context:
space:
mode:
authorMarek Belisko <marek.belisko@open-nandra.com>2011-05-18 18:08:27 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-06-27 00:48:13 +0200
commit24d498dadf35db72a1a8d173c071def9b0c66361 (patch)
treea718ea966a89d0909495be7dd81733552c2256ea /package/libiqrf
parent001949a1e0aafc6d5dec384f20ccd9059142f774 (diff)
downloadbuildroot-novena-24d498dadf35db72a1a8d173c071def9b0c66361.tar.gz
buildroot-novena-24d498dadf35db72a1a8d173c071def9b0c66361.zip
package: Add libiqrf package
Libiqrf is library written in C which implement specific iqrf protocol to communicate with iqrf usb devices (http://iqrf.org). [Peter: select libusb, fix Config.in indentation] Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libiqrf')
-rw-r--r--package/libiqrf/Config.in10
-rw-r--r--package/libiqrf/libiqrf.mk14
2 files changed, 24 insertions, 0 deletions
diff --git a/package/libiqrf/Config.in b/package/libiqrf/Config.in
new file mode 100644
index 000000000..aa2501097
--- /dev/null
+++ b/package/libiqrf/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LIBIQRF
+ bool "libiqrf"
+ select BR2_PACKAGE_LIBUSB
+ help
+ This library implement specific protocol
+ which is used for communicating with iqrf devices
+ (http://iqrf.org) over usb. For usb access is used
+ libusb library.
+
+ https://github.com/nandra/libiqrf
diff --git a/package/libiqrf/libiqrf.mk b/package/libiqrf/libiqrf.mk
new file mode 100644
index 000000000..e3c4bb1da
--- /dev/null
+++ b/package/libiqrf/libiqrf.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# libiqrf library
+#
+#############################################################
+
+LIBIQRF_VERSION = v0.1.0
+LIBIQRF_SITE = git://github.com/nandra/libiqrf.git
+LIBIQRF_INSTALL_STAGING = YES
+
+LIBIQRF_DEPENDENCIES = libusb
+
+$(eval $(call AUTOTARGETS,package,libiqrf))
+