summaryrefslogtreecommitdiffstats
path: root/package/libgtk2
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 22:40:38 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:25:00 +0200
commit39c781f33a7cf486c4872181cce8451913d06407 (patch)
treec62ee477310c50b3597a971184b16e28283b2623 /package/libgtk2
parentfa6c7989acb94e4df7ab42cec252d946e8fb0c43 (diff)
downloadbuildroot-novena-39c781f33a7cf486c4872181cce8451913d06407.tar.gz
buildroot-novena-39c781f33a7cf486c4872181cce8451913d06407.zip
libgtk2: convert old-style hook to new-style
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libgtk2')
-rw-r--r--package/libgtk2/libgtk2.mk12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/libgtk2/libgtk2.mk b/package/libgtk2/libgtk2.mk
index 1e732d08d..d669622a8 100644
--- a/package/libgtk2/libgtk2.mk
+++ b/package/libgtk2/libgtk2.mk
@@ -119,6 +119,13 @@ else
LIBGTK2_CONF_OPT += --disable-cups
endif
+define LIBGTK2_POST_INSTALL_TWEAKS
+ $(INSTALL) -m 755 package/libgtk2/S26libgtk2 $(TARGET_DIR)/etc/init.d/
+ rm -rf $(TARGET_DIR)/usr/share/gtk-2.0/demo $(TARGET_DIR)/usr/bin/gtk-demo
+endef
+
+LIBGTK2_POST_INSTALL_TARGET_HOOKS += LIBGTK_POST_INSTALL_TWEAKS
+
# We do not build a full version of libgtk2 for the host, because that
# requires compiling Cairo, Pango, ATK and X.org for the
# host. Therefore, we patch it to remove dependencies, and we hack the
@@ -155,8 +162,3 @@ endef
$(eval $(call AUTOTARGETS,package,libgtk2))
$(eval $(call AUTOTARGETS,package,libgtk2,host))
-
-$(LIBGTK2_HOOK_POST_INSTALL):
- $(INSTALL) -m 755 package/libgtk2/S26libgtk2 $(TARGET_DIR)/etc/init.d/
- rm -rf $(TARGET_DIR)/usr/share/gtk-2.0/demo $(TARGET_DIR)/usr/bin/gtk-demo
- touch $@