summaryrefslogtreecommitdiffstats
path: root/package/libglib2
diff options
context:
space:
mode:
authorBenoît Thébaudeau <benoit.thebaudeau@advansee.com>2012-12-17 10:05:40 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-18 09:37:35 +0100
commit9a7e06dc83b70eaed900ab5078206e1c7d0ce141 (patch)
tree2bd1ace301cd01f549ec3bfc3601cec6f96d11b1 /package/libglib2
parent69c045d5fbaf54b9468a99f5bbf2c531b2aef335 (diff)
downloadbuildroot-novena-9a7e06dc83b70eaed900ab5078206e1c7d0ce141.tar.gz
buildroot-novena-9a7e06dc83b70eaed900ab5078206e1c7d0ce141.zip
libglib2: fix g_print()
If GLib is cross-compiled, the default printf settings that it selects are wrong for glibc. This leads to issues with the g_print() functions, e.g. "Aborted" errors returned by gst-inspect. This patch fixes this issue by setting printf configuration options compatible with glibc. These options should also be compatible with uClibc. This solution has been suggested for LTIB by Rogerio Nunes: https://community.freescale.com/thread/302734 Signed-off-by: Benoît Thébaudeau <benoit.thebaudeau@advansee.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libglib2')
-rw-r--r--package/libglib2/libglib2.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libglib2/libglib2.mk b/package/libglib2/libglib2.mk
index 44274315c..c3e510b12 100644
--- a/package/libglib2/libglib2.mk
+++ b/package/libglib2/libglib2.mk
@@ -40,7 +40,8 @@ LIBGLIB2_CONF_ENV = \
ac_cv_func_working_mktime=yes jm_cv_func_working_re_compile_pattern=yes \
ac_use_included_regex=no gl_cv_c_restrict=no \
ac_cv_path_GLIB_GENMARSHAL=$(HOST_DIR)/usr/bin/glib-genmarshal ac_cv_prog_F77=no \
- ac_cv_func_posix_getgrgid_r=no \
+ ac_cv_func_posix_getgrgid_r=no glib_cv_long_long_format=ll \
+ ac_cv_func_printf_unix98=yes ac_cv_func_vsnprintf_c99=yes \
gt_cv_c_wchar_t=$(if $(BR2_USE_WCHAR),yes,no)
# old uClibc versions don't provide qsort_r