summaryrefslogtreecommitdiffstats
path: root/package/libglib2/libglib2.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-12 15:59:14 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-24 09:30:40 +0200
commit0ec4298153bd93f8d7efbd1890896fbac5046a7b (patch)
treefe1abc30c1d1268b6557fd632e42cd6f2aef6e25 /package/libglib2/libglib2.mk
parent30887f616a11e74b786677a66226d3a5d47d8f8a (diff)
downloadbuildroot-novena-0ec4298153bd93f8d7efbd1890896fbac5046a7b.tar.gz
buildroot-novena-0ec4298153bd93f8d7efbd1890896fbac5046a7b.zip
libglib2: add patch to rework clock_gettime() test
The test for clock_gettime() in configure.in doesn't work properly when a previous package has loaded the shared configuration cache with informations about the availability of clock_gettime. A package such as ctorrent does so, which means that compiling ctorrent *then* libglib2 currently fails. According to people on the Autoconf mailing list, the libglib2 test is likely the one that needs to be fixed. The problem is that the AC_CHECK_FUNCS() test assumes that if it finds clock_gettime() it means that there's no need to add any -lrt flag to the build. Unfortunately, due to the shared configuration cache, this test is already done with -lrt, so the test succeeds, and libglib2 does not know that it needs to add -lrt to G_THREAD_LIBS and G_THREAD_LIBS_FOR_GTHREAD. So instead, we remplace the test with an AC_SEARCH_LIBS() test, followed by a test on the result of this AC_SEARCH_LIBS() test to add the necessary -lrt to G_THREAD_LIBS and G_THREAD_LIBS_FOR_GTHREAD. Therefore, even if the result for the AC_SEARCH_LIBS() test is cached due to the prior execution ctorrent ./configure script, libglib2 ./configure will properly add -lrt to the appropriate variables. Obviously, as this patch modifies the configure.in file, we enable the autoreconf step for the libglib2 package. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libglib2/libglib2.mk')
-rw-r--r--package/libglib2/libglib2.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libglib2/libglib2.mk b/package/libglib2/libglib2.mk
index 8dc1fcb83..61e8c1c38 100644
--- a/package/libglib2/libglib2.mk
+++ b/package/libglib2/libglib2.mk
@@ -9,7 +9,7 @@ LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).$(LIBGLIB2_VERSION_MINOR)
LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.bz2
LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
-LIBGLIB2_AUTORECONF = NO
+LIBGLIB2_AUTORECONF = YES
LIBGLIB2_LIBTOOL_PATCH = NO
LIBGLIB2_INSTALL_STAGING = YES
LIBGLIB2_INSTALL_TARGET = YES