summaryrefslogtreecommitdiffstats
path: root/package/libgcrypt
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-19 12:20:52 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-19 12:20:52 +0000
commitf1bcdf518fa7868b7819b0248f4b8da02a954dde (patch)
tree9717e9ec3bc9e7ebb8d930fd04808b98fe41b069 /package/libgcrypt
parent721599538656b49ccd037cdc345bba710c4cdbc7 (diff)
downloadbuildroot-novena-f1bcdf518fa7868b7819b0248f4b8da02a954dde.tar.gz
buildroot-novena-f1bcdf518fa7868b7819b0248f4b8da02a954dde.zip
- fix incorrect setting of $ac_cv_sys_symbol_underscore.
There is no reason not to AC_COMPILE and use the set cross-nm to look for the symbol mangling scheme. Thus it is incorrect to check for cross compilation in the GNUPG_SYS_SYMBOL_UNDERSCORE check. - fix bug when configuring (has to wipe config.cache !)
Diffstat (limited to 'package/libgcrypt')
-rw-r--r--package/libgcrypt/libgcrypt-00-ac_cv_sys_symbol_underscore.patch24
-rw-r--r--package/libgcrypt/libgcrypt-01-reconfigure.patch17
-rw-r--r--package/libgcrypt/libgcrypt.mk7
3 files changed, 46 insertions, 2 deletions
diff --git a/package/libgcrypt/libgcrypt-00-ac_cv_sys_symbol_underscore.patch b/package/libgcrypt/libgcrypt-00-ac_cv_sys_symbol_underscore.patch
new file mode 100644
index 000000000..fe713601e
--- /dev/null
+++ b/package/libgcrypt/libgcrypt-00-ac_cv_sys_symbol_underscore.patch
@@ -0,0 +1,24 @@
+diff -u libgcrypt-1.2.4.oorig/acinclude.m4 libgcrypt-1.2.4/acinclude.m4
+--- libgcrypt-1.2.4.oorig/acinclude.m4 2005-07-29 15:45:48.000000000 +0200
++++ libgcrypt-1.2.4/acinclude.m4 2007-09-19 13:33:19.000000000 +0200
+@@ -99,12 +99,14 @@
+ i386-emx-os2 | i[3456]86-pc-os2*emx | i386-pc-msdosdjgpp)
+ ac_cv_sys_symbol_underscore=yes
+ ;;
+- *)
+- if test "$cross_compiling" = yes; then
+- ac_cv_sys_symbol_underscore=yes
+- else
+- tmp_do_check="yes"
+- fi
++ *) if test -z "$ac_cv_sys_symbol_underscore"; then
++ if test "$cross_compiling" = yes &&
++ then
++ ac_cv_sys_symbol_underscore=yes
++ else
++ tmp_do_check="yes"
++ fi
++ fi
+ ;;
+ esac
+ if test "$tmp_do_check" = "yes"; then
diff --git a/package/libgcrypt/libgcrypt-01-reconfigure.patch b/package/libgcrypt/libgcrypt-01-reconfigure.patch
new file mode 100644
index 000000000..963ae8b5a
--- /dev/null
+++ b/package/libgcrypt/libgcrypt-01-reconfigure.patch
@@ -0,0 +1,17 @@
+--- libgcrypt-1.2.4.oorig/configure 2007-09-19 13:40:48.000000000 +0200
++++ libgcrypt-1.2.4/configure 2007-09-19 13:41:44.000000000 +0200
+@@ -27370,12 +27370,13 @@
+ i386-emx-os2 | i345686-pc-os2*emx | i386-pc-msdosdjgpp)
+ ac_cv_sys_symbol_underscore=yes
+ ;;
+- *)
++ *)if test -z "$ac_cv_sys_symbol_underscore";then
+ if test "$cross_compiling" = yes; then
+ ac_cv_sys_symbol_underscore=yes
+ else
+ tmp_do_check="yes"
+ fi
++ fi
+ ;;
+ esac
+ if test "$tmp_do_check" = "yes"; then
diff --git a/package/libgcrypt/libgcrypt.mk b/package/libgcrypt/libgcrypt.mk
index 8436222af..8f145bad5 100644
--- a/package/libgcrypt/libgcrypt.mk
+++ b/package/libgcrypt/libgcrypt.mk
@@ -18,12 +18,16 @@ $(LIBGCRYPT_DIR)/.source: $(DL_DIR)/$(LIBGCRYPT_SOURCE)
$(BZCAT) $(DL_DIR)/$(LIBGCRYPT_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(LIBGCRYPT_DIR) package/libgcrypt/ libgcrypt\*.patch
$(CONFIG_UPDATE) $(LIBGCRYPT_DIR)
+ # This is incorrectly hardwired to yes for cross-compiles with no
+ # sane way to pass pre-existing knowledge so fix it with the chainsaw..
+ $(SED) '/GNUPG_SYS_SYMBOL_UNDERSCORE/d' $(LIBGCRYPT_DIR)/configure
touch $@
$(LIBGCRYPT_DIR)/.configured: $(LIBGCRYPT_DIR)/.source
- (cd $(LIBGCRYPT_DIR); \
+ (cd $(LIBGCRYPT_DIR); rm -f config.cache; \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
+ ac_cv_sys_symbol_underscore=no \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -41,7 +45,6 @@ $(LIBGCRYPT_DIR)/.configured: $(LIBGCRYPT_DIR)/.source
--mandir=/usr/man \
--infodir=/usr/info \
--disable-optimization \
- --with-capabilities \
)
touch $@