summaryrefslogtreecommitdiffstats
path: root/package/libfuse
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-09-07 01:59:18 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-07 15:29:17 +0200
commita9e4e1b676758f1004bebdd1fd409b8976ebc6ca (patch)
tree7647c11188fabfeafa79c1c1b50280a328066ca4 /package/libfuse
parent58149528d09b3342477beb3f5abce83775acdaff (diff)
downloadbuildroot-novena-a9e4e1b676758f1004bebdd1fd409b8976ebc6ca.tar.gz
buildroot-novena-a9e4e1b676758f1004bebdd1fd409b8976ebc6ca.zip
libfuse: fix build failures with iconv
Fix build failures when iconv is present for libfuse users that use pkgconfig. For example: http://autobuild.buildroot.net/results/4d455831a7b467b9ea1ad54bea6b57607f5560a8/build-end.log Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libfuse')
-rw-r--r--package/libfuse/libfuse-iconv.patch18
-rw-r--r--package/libfuse/libfuse.mk2
2 files changed, 19 insertions, 1 deletions
diff --git a/package/libfuse/libfuse-iconv.patch b/package/libfuse/libfuse-iconv.patch
new file mode 100644
index 000000000..9f500321a
--- /dev/null
+++ b/package/libfuse/libfuse-iconv.patch
@@ -0,0 +1,18 @@
+Upstream commit efeac22bfa65c845c04adb5e70e6de33b0104fa3 but without
+the need to autoreconf :)
+Fixes libiconv missing in fuse.pc
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura fuse-2.9.1/configure fuse-2.9.1.iconv/configure
+--- fuse-2.9.1/configure 2012-07-19 09:53:29.000000000 -0300
++++ fuse-2.9.1.iconv/configure 2012-09-07 08:47:57.834912620 -0300
+@@ -13237,7 +13237,7 @@
+
+ fi
+
+-libfuse_libs=$libfuse_libs $LTLIBICONV
++libfuse_libs="$libfuse_libs $LTLIBICONV"
+ if test "$am_cv_func_iconv" = yes; then
+ ICONV_TRUE=
+ ICONV_FALSE='#'
diff --git a/package/libfuse/libfuse.mk b/package/libfuse/libfuse.mk
index c8c01303d..779115bfe 100644
--- a/package/libfuse/libfuse.mk
+++ b/package/libfuse/libfuse.mk
@@ -9,8 +9,8 @@ LIBFUSE_SOURCE = fuse-$(LIBFUSE_VERSION).tar.gz
LIBFUSE_SITE = http://downloads.sourceforge.net/project/fuse/fuse-2.X/$(LIBFUSE_VERSION)
LIBFUSE_LICENSE = GPLv2 LGPLv2.1
LIBFUSE_LICENSE_FILES = COPYING COPYING.LIB
-
LIBFUSE_INSTALL_STAGING = YES
+LIBFUSE_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
LIBFUSE_CONF_OPT= --disable-nls \
--disable-example \
--disable-kernel-module \