summaryrefslogtreecommitdiffstats
path: root/package/libffi
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-12-28 05:35:39 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-28 16:55:09 +0100
commit4848386446b937d4d0d9d3e9489932ca3fcb1003 (patch)
tree37f09d965152388a8afdcd06f75c4d5cc8acc88d /package/libffi
parentec10d81e46cbcbb644dcfe0f91961fb09706be77 (diff)
downloadbuildroot-novena-4848386446b937d4d0d9d3e9489932ca3fcb1003.tar.gz
buildroot-novena-4848386446b937d4d0d9d3e9489932ca3fcb1003.zip
libffi: fix mips build failures
Fixes http://autobuild.buildroot.net/results/c4056ed2b969b900f7654e651e0e4cc2e8998e02 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libffi')
-rw-r--r--package/libffi/libffi.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/libffi/libffi.mk b/package/libffi/libffi.mk
index 75705835e..64b3eb412 100644
--- a/package/libffi/libffi.mk
+++ b/package/libffi/libffi.mk
@@ -8,9 +8,14 @@ LIBFFI_VERSION = 3.0.11
LIBFFI_SITE = ftp://sources.redhat.com/pub/libffi/
LIBFFI_LICENSE = MIT
LIBFFI_LICENSE_FILES = LICENSE
-
LIBFFI_INSTALL_STAGING = YES
+# Newer CS MIPS toolchains use a different (compact) eh_frame format
+# libffi don't like them, just switch to the older format
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201209)$(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203),y)
+LIBFFI_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -mno-compact-eh"
+endif
+
# Move the headers to the usual location, and adjust the .pc file
# accordingly
define LIBFFI_MOVE_STAGING_HEADERS