summaryrefslogtreecommitdiffstats
path: root/package/libfcgi/libfcgi-make-autoreconfable.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-05-06 04:56:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-06 17:39:15 +0200
commit4326f0020d31e17ccdc1ef991bbc50bdddc47abf (patch)
tree3fb8af00834f5468dd1fbbaa522b3ee3e3dfdd93 /package/libfcgi/libfcgi-make-autoreconfable.patch
parented7b3362ad6dc33899766c803bba51240111aa43 (diff)
downloadbuildroot-novena-4326f0020d31e17ccdc1ef991bbc50bdddc47abf.tar.gz
buildroot-novena-4326f0020d31e17ccdc1ef991bbc50bdddc47abf.zip
libfcgi: fix build problem of libfcgi++
Fix the way libfcgi++ is linked against libfcgi to solve the http://autobuild.buildroot.org/results/f8e88e93f32e4e94ac9aef5a3f3f2826f1970453/build-end.log build problem. Since we're fixing Makefile.am, take that opportunity to add -lm where needed, to avoid the need of using custom LDFLAGS in libfcgi.mk. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libfcgi/libfcgi-make-autoreconfable.patch')
-rw-r--r--package/libfcgi/libfcgi-make-autoreconfable.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/package/libfcgi/libfcgi-make-autoreconfable.patch b/package/libfcgi/libfcgi-make-autoreconfable.patch
new file mode 100644
index 000000000..e255fc6d3
--- /dev/null
+++ b/package/libfcgi/libfcgi-make-autoreconfable.patch
@@ -0,0 +1,67 @@
+Make the package autoreconfigurable
+
+Adjust minor details in Makefile.am and configure.in in order to make
+the package compatible with the autoconf/automake versions we are
+using in Buildroot.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/cgi-fcgi/Makefile.am
+===================================================================
+--- a/cgi-fcgi/Makefile.am
++++ b/cgi-fcgi/Makefile.am
+@@ -2,7 +2,7 @@
+ bin_PROGRAMS = cgi-fcgi
+
+ INCLUDEDIR = ../include
+-CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
++AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
+
+ INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
+ $(INCLUDEDIR)/fcgiapp.h \
+Index: b/configure.in
+===================================================================
+--- a/configure.in
++++ b/configure.in
+@@ -4,12 +4,13 @@
+ dnl generate the file "configure", which is run during the build
+ dnl to configure the system for the local environment.
+
+-AC_INIT
+-AM_INIT_AUTOMAKE(fcgi, 2.4.0)
++AC_INIT([fcgi], [2.4.0])
++AM_INIT_AUTOMAKE([foreign])
+
+ AM_CONFIG_HEADER(fcgi_config.h)
+
+ AC_PROG_CC
++AC_PROG_CC_C_O
+ AC_PROG_CPP
+ AC_PROG_INSTALL
+ AC_PROG_LIBTOOL
+Index: b/examples/Makefile.am
+===================================================================
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -11,7 +11,7 @@
+ EXTRA_PROGRAMS = threaded echo-cpp
+
+ INCLUDEDIR = ../include
+-CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
++AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
+
+ INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
+ $(INCLUDEDIR)/fcgiapp.h \
+Index: b/libfcgi/Makefile.am
+===================================================================
+--- a/libfcgi/Makefile.am
++++ b/libfcgi/Makefile.am
+@@ -1,7 +1,7 @@
+ # $Id: Makefile.am,v 1.9 2001/12/22 03:16:20 robs Exp $
+
+ INCLUDEDIR = ../include
+-CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
++AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
+
+ INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
+ $(INCLUDEDIR)/fcgiapp.h \