summaryrefslogtreecommitdiffstats
path: root/package/libfcgi/libfcgi-link-against-math.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-05-06 04:56:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-06 17:39:15 +0200
commit4326f0020d31e17ccdc1ef991bbc50bdddc47abf (patch)
tree3fb8af00834f5468dd1fbbaa522b3ee3e3dfdd93 /package/libfcgi/libfcgi-link-against-math.patch
parented7b3362ad6dc33899766c803bba51240111aa43 (diff)
downloadbuildroot-novena-4326f0020d31e17ccdc1ef991bbc50bdddc47abf.tar.gz
buildroot-novena-4326f0020d31e17ccdc1ef991bbc50bdddc47abf.zip
libfcgi: fix build problem of libfcgi++
Fix the way libfcgi++ is linked against libfcgi to solve the http://autobuild.buildroot.org/results/f8e88e93f32e4e94ac9aef5a3f3f2826f1970453/build-end.log build problem. Since we're fixing Makefile.am, take that opportunity to add -lm where needed, to avoid the need of using custom LDFLAGS in libfcgi.mk. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libfcgi/libfcgi-link-against-math.patch')
-rw-r--r--package/libfcgi/libfcgi-link-against-math.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/libfcgi/libfcgi-link-against-math.patch b/package/libfcgi/libfcgi-link-against-math.patch
new file mode 100644
index 000000000..4c87ea678
--- /dev/null
+++ b/package/libfcgi/libfcgi-link-against-math.patch
@@ -0,0 +1,28 @@
+Link against math libraries when needed
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/cgi-fcgi/Makefile.am
+===================================================================
+--- a/cgi-fcgi/Makefile.am
++++ b/cgi-fcgi/Makefile.am
+@@ -11,5 +11,5 @@
+ LIBDIR = ../libfcgi
+ LIBFCGI = $(LIBDIR)/libfcgi.la
+
+-LDADD = $(LIBFCGI)
++LDADD = $(LIBFCGI) -lm
+ cgi_fcgi_SOURCES = $(INCLUDE_FILES) cgi-fcgi.c
+Index: b/examples/Makefile.am
+===================================================================
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -21,7 +21,7 @@
+ LIBDIR = ../libfcgi
+ LIBFCGI = $(LIBDIR)/libfcgi.la
+
+-LDADD = $(LIBFCGI)
++LDADD = $(LIBFCGI) -lm
+
+ echo_SOURCES = $(INCLUDE_FILES) echo.c
+ echo_x_SOURCES = $(INCLUDE_FILES) echo-x.c