summaryrefslogtreecommitdiffstats
path: root/package/libevent
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 17:13:56 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:24:58 +0200
commit3c6985d309a37217196877bc87a84967ad2dd213 (patch)
treeac3ec04fb07467fc5818e8d2a941fce4d22937d0 /package/libevent
parent1c8e89f4ce9a13fb1050426e3f31a3e23598b125 (diff)
downloadbuildroot-novena-3c6985d309a37217196877bc87a84967ad2dd213.tar.gz
buildroot-novena-3c6985d309a37217196877bc87a84967ad2dd213.zip
libevent: convert old-style hook to new-style hook
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libevent')
-rw-r--r--package/libevent/libevent.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/package/libevent/libevent.mk b/package/libevent/libevent.mk
index f71bf9a11..4df627087 100644
--- a/package/libevent/libevent.mk
+++ b/package/libevent/libevent.mk
@@ -12,12 +12,14 @@ LIBEVENT_LIBTOOL_PATCH = NO
LIBEVENT_INSTALL_STAGING = YES
LIBEVENT_INSTALL_TARGET = YES
-$(eval $(call AUTOTARGETS,package,libevent))
+define LIBEVENT_REMOVE_PYSCRIPT
+ rm $(TARGET_DIR)/usr/bin/event_rpcgen.py
+endef
+# libevent installs a python script to target - get rid of it if we
+# don't have python support enabled
ifneq ($(BR2_PACKAGE_PYTHON),y)
-# libevent installs a python script to target - get rid of it if
-# we don't have python support enabled
-$(LIBEVENT_HOOK_POST_INSTALL):
- rm $(TARGET_DIR)/usr/bin/event_rpcgen.py
- touch $@
+LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
endif
+
+$(eval $(call AUTOTARGETS,package,libevent))