summaryrefslogtreecommitdiffstats
path: root/package/liberation
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-10-20 07:30:03 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-10-20 07:30:03 +0000
commit988163764ecd72f113162e0880e8bac7e06e65b2 (patch)
tree783061241c224ff401a6b488d70483411e4277fb /package/liberation
parentb0457a0ab716f6f3322d9a87a86ca8def8fded17 (diff)
downloadbuildroot-novena-988163764ecd72f113162e0880e8bac7e06e65b2.tar.gz
buildroot-novena-988163764ecd72f113162e0880e8bac7e06e65b2.zip
package/liberation: Add liberation fonts package
Add the liberation fonts package as this can be used by GTK etc and means you have some useful (free) fonts. Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
Diffstat (limited to 'package/liberation')
-rw-r--r--package/liberation/Config.in7
-rw-r--r--package/liberation/liberation.mk47
2 files changed, 54 insertions, 0 deletions
diff --git a/package/liberation/Config.in b/package/liberation/Config.in
new file mode 100644
index 000000000..48d4195ba
--- /dev/null
+++ b/package/liberation/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LIBERATION
+ bool "Liberation (Free fonts)"
+ help
+ The Liberation Fonts are intended to be replacements for the
+ three most commonly used fonts on Microsoft systems:
+ Times New Roman, Arial, and Courier New.
+
diff --git a/package/liberation/liberation.mk b/package/liberation/liberation.mk
new file mode 100644
index 000000000..653aea5e0
--- /dev/null
+++ b/package/liberation/liberation.mk
@@ -0,0 +1,47 @@
+#############################################################
+#
+# liberation
+#
+#############################################################
+LIBERATION_VERSION = 1.04
+LIBERATION_SITE = http://www.fedorahosted.org/releases/l/i/liberation-fonts
+LIBERATION_SOURCE = liberation-fonts-$(LIBERATION_VERSION).tar.gz
+LIBERATION_DIR = $(BUILD_DIR)/liberation-fonts-$(LIBERATION_VERSION)
+LIBERATION_CAT:=$(ZCAT)
+
+$(DL_DIR)/$(LIBERATION_SOURCE):
+ $(WGET) -P $(DL_DIR) $(LIBERATION_SITE)/$(LIBERATION_SOURCE)
+
+liberation-source: $(DL_DIR)/$(LIBERATION_SOURCE)
+
+$(LIBERATION_DIR)/.unpacked: $(DL_DIR)/$(LIBERATION_SOURCE)
+ $(LIBERATION_CAT) $(DL_DIR)/$(LIBERATION_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $(LIBERATION_DIR)/.unpacked
+
+$(STAGING_DIR)/usr/share/fonts/LiberationMono-Bold.ttf: $(LIBERATION_DIR)/.unpacked
+ -mkdir -p $(STAGING_DIR)/usr/share/fonts/liberation
+ $(INSTALL) -m0644 $(LIBERATION_DIR)/*.ttf $(STAGING_DIR)/usr/share/fonts/liberation/
+ touch -c $(STAGING_DIR)/usr/share/fonts/.ttf
+
+$(TARGET_DIR)/usr/share/fonts/LiberationMono-Bold.ttf: $(STAGING_DIR)/usr/share/fonts/.ttf
+ -mkdir -p $(TARGET_DIR)/usr/share/fonts/liberation
+ $(INSTALL) -m0644 $(LIBERATION_DIR)/*.ttf $(TARGET_DIR)/usr/share/fonts/liberation/
+ touch -c $(TARGET_DIR)/usr/share/fonts/.ttf
+
+liberation: uclibc $(TARGET_DIR)/usr/share/fonts/LiberationMono-Bold.ttf
+
+liberation-clean:
+ rm -rf $(TARGET_DIR)/usr/share/fonts/liberation/
+ rm -rf $(STAGING_DIR)/usr/share/fonts/liberation/
+
+liberation-dirclean:
+ rm -rf $(LIBERATION_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LIBERATION)),y)
+TARGETS+=liberation
+endif