summaryrefslogtreecommitdiffstats
path: root/package/libelf
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-10-02 15:38:27 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-10-02 15:38:27 +0000
commitf393387661ce72dbf6a2271e24c64a5a535bb752 (patch)
tree9bddeef91bed057c423a5124e944168a166b6b4b /package/libelf
parent378a02b3661e1974d477715081f88a81fdcde74a (diff)
downloadbuildroot-novena-f393387661ce72dbf6a2271e24c64a5a535bb752.tar.gz
buildroot-novena-f393387661ce72dbf6a2271e24c64a5a535bb752.zip
- make sure that the target's usr/include dir exists when installing the headers
It would make sense to provide a $(PREREQ_TARGETDIR_USR_INCLUDE) prerequisite that expands to $(TARGET_DIR)/usr/include if installing any headers was requested to fix this in a generic manner..
Diffstat (limited to 'package/libelf')
-rw-r--r--package/libelf/libelf.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libelf/libelf.mk b/package/libelf/libelf.mk
index af06ba8b1..51c4b4b1d 100644
--- a/package/libelf/libelf.mk
+++ b/package/libelf/libelf.mk
@@ -57,7 +57,9 @@ $(STAGING_DIR)/usr/lib/libelf.a $(STAGING_DIR)/usr/lib/libelf.so.$(LIBELF_VERSIO
ifeq ($(BR2_PACKAGE_LIBELF_HEADERS),y)
$(TARGET_DIR)/usr/lib/libelf.so.$(LIBELF_VERSION): $(STAGING_DIR)/usr/lib/libelf.a
- $(INSTALL) $(STAGING_DIR)/usr/lib/libelf* $(@D)
+ mkdir -p $(@D)
+ cp -dpf $(STAGING_DIR)/usr/lib/libelf* $(@D)
+ mkdir -p $(TARGET_DIR)/usr/include
cp -dpR $(STAGING_DIR)/usr/include/{gelf.h,libelf*} $(TARGET_DIR)/usr/include/
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@