summaryrefslogtreecommitdiffstats
path: root/package/libdvbsi
diff options
context:
space:
mode:
authorCarsten Schoenert <c.schoenert@gmail.com>2013-06-23 17:30:33 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-27 21:30:52 +0200
commit84f2dece13cbadd6f87c6223c1f452b5446633a4 (patch)
tree80a5e990c822a636fba54a2fd14b1d1b5359ec79 /package/libdvbsi
parent241a6c9bcf75753338cb017fcac4e2d8bc9d90d7 (diff)
downloadbuildroot-novena-84f2dece13cbadd6f87c6223c1f452b5446633a4.tar.gz
buildroot-novena-84f2dece13cbadd6f87c6223c1f452b5446633a4.zip
package/libdvbsi: new package
libdvbsi++ is a C++ library for parsing DVB SI sections and providing the output in C++ objects. It's usefull in any case you need prepared and preselected DVB SI data from the raw stream. [Peter: fix _LICENSE_FILES tag] Signed-off-by: Carsten Schoenert <c.schoenert@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libdvbsi')
-rw-r--r--package/libdvbsi/Config.in14
-rw-r--r--package/libdvbsi/libdvbsi.mk17
2 files changed, 31 insertions, 0 deletions
diff --git a/package/libdvbsi/Config.in b/package/libdvbsi/Config.in
new file mode 100644
index 000000000..0d3143fce
--- /dev/null
+++ b/package/libdvbsi/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LIBDVBSI
+ bool "libdvbsi"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_WCHAR
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ C++ parsing library for Service Information (SI) in DVB systems.
+ With libdvbsi++ you can convert raw DVB service information to
+ a set of C++ objects, removing the need to parse data manually.
+
+ http://www.saftware.de/
+
+comment "libdvbsi++ requires a toolchain with C++, WCHAR and threads support"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libdvbsi/libdvbsi.mk b/package/libdvbsi/libdvbsi.mk
new file mode 100644
index 000000000..3e991776b
--- /dev/null
+++ b/package/libdvbsi/libdvbsi.mk
@@ -0,0 +1,17 @@
+################################################################################
+#
+# libdvbsi++
+#
+################################################################################
+
+LIBDVBSI_VERSION = 0.3.6
+LIBDVBSI_SOURCE = libdvbsi++-$(LIBDVBSI_VERSION).tar.bz2
+LIBDVBSI_SITE = http://www.saftware.de/libdvbsi++
+LIBDVBSI_INSTALL_STAGING = YES
+LIBDVBSI_LICENSE = LGPLv2.1
+LIBDVBSI_LICENSE_FILES = COPYING
+
+# sometimes no Makefile is in the archive, just (re)generate
+LIBDVBSI_AUTORECONF=YES
+
+$(eval $(autotools-package))