summaryrefslogtreecommitdiffstats
path: root/package/libdaemon
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/libdaemon
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/libdaemon')
-rw-r--r--package/libdaemon/libdaemon.mk13
1 files changed, 4 insertions, 9 deletions
diff --git a/package/libdaemon/libdaemon.mk b/package/libdaemon/libdaemon.mk
index ad1cda585..766cfa309 100644
--- a/package/libdaemon/libdaemon.mk
+++ b/package/libdaemon/libdaemon.mk
@@ -41,13 +41,14 @@ $(LIBDAEMON_DIR)/.configured: $(LIBDAEMON_DIR)/.unpacked
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
- --libexecdir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
+ --includedir=/include \
--mandir=/usr/man \
--infodir=/usr/info \
- --includedir=$(STAGING_DIR)/include \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
--disable-lynx \
@@ -60,13 +61,7 @@ $(LIBDAEMON_DIR)/.compiled: $(LIBDAEMON_DIR)/.configured
touch $(LIBDAEMON_DIR)/.compiled
$(STAGING_DIR)/lib/libdaemon.a: $(LIBDAEMON_DIR)/.compiled
- $(MAKE) \
- -C $(LIBDAEMON_DIR) \
- prefix=$(STAGING_DIR) \
- exec_prefix=$(STAGING_DIR) \
- bindir=$(STAGING_DIR)/bin \
- datadir=$(STAGING_DIR)/share \
- install
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBDAEMON_DIR) install
touch -c $(STAGING_DIR)/lib/libdaemon.a
#$(TARGET_DIR)/usr/lib/libdaemon.a: $(STAGING_DIR)/lib/libdaemon.a