summaryrefslogtreecommitdiffstats
path: root/package/libcurl
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-12-28 20:04:01 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-12-28 20:04:01 +0000
commit84c556006d3c5349702016d75a6f123b27d4b735 (patch)
treee7b0cd7ccee753c2c6822a7cefcfacf3d3cef3d5 /package/libcurl
parent615528ba939d4c54f3b7630b6422496b38482549 (diff)
downloadbuildroot-novena-84c556006d3c5349702016d75a6f123b27d4b735.tar.gz
buildroot-novena-84c556006d3c5349702016d75a6f123b27d4b735.zip
libcurl: compile with openssl support if available
Diffstat (limited to 'package/libcurl')
-rw-r--r--package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch25
-rw-r--r--package/libcurl/libcurl.mk6
2 files changed, 31 insertions, 0 deletions
diff --git a/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch b/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch
new file mode 100644
index 000000000..b15ed9631
--- /dev/null
+++ b/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch
@@ -0,0 +1,25 @@
+ssluse.c: fix build breakage with --with-ssl --disable-verbose
+
+Revision 1.206 of ssluse.c removed the prefix argument to asn1_output,
+but it is still referenced in the CURL_DISABLE_VERBOSE_STRINGS case.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ lib/ssluse.c | 4 ----
+ 1 file changed, 4 deletions(-)
+
+Index: curl-7.19.2/lib/ssluse.c
+===================================================================
+--- curl-7.19.2.orig/lib/ssluse.c
++++ curl-7.19.2/lib/ssluse.c
+@@ -923,10 +923,6 @@
+ int i;
+ int year=0,month=0,day=0,hour=0,minute=0,second=0;
+
+-#ifdef CURL_DISABLE_VERBOSE_STRINGS
+- (void)prefix;
+-#endif
+-
+ i=tm->length;
+ asn1_string=(const char *)tm->data;
+
diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index 60ed3623d..328400449 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -10,6 +10,12 @@ LIBCURL_INSTALL_STAGING = YES
LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols \
$(DISABLE_NLS) $(DISABLE_LARGEFILE) $(DISABLE_IPV6)
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBCURL_DEPENDENCIES += openssl
+LIBCURL_CONF_ENV += ac_cv_lib_crypto_CRYPTO_lock=yes
+LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr --with-random=/dev/urandom
+endif
+
$(eval $(call AUTOTARGETS,package,libcurl))
$(LIBCURL_HOOK_POST_INSTALL):