summaryrefslogtreecommitdiffstats
path: root/package/libcurl
diff options
context:
space:
mode:
authorShawn J. Goff <shawn7400@gmail.com>2013-04-17 11:31:27 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-21 23:15:08 +0200
commit4f3c8cf94bd610f60c6963cb6c1df041a1ebb7f3 (patch)
treefcb161cae807249b923ad7887729dcd8d5a1cd5c /package/libcurl
parentf39b706b087865112e351503ee51c60e5c2453f5 (diff)
downloadbuildroot-novena-4f3c8cf94bd610f60c6963cb6c1df041a1ebb7f3.tar.gz
buildroot-novena-4f3c8cf94bd610f60c6963cb6c1df041a1ebb7f3.zip
libcurl: specify capath
Since openssl's path is '/etc/ssl/' (specified in our openssl package), we should also make sure that's what curl is using. Previously, it's hasn't been specified, which means it changes depending on the host system where it's compiled. Signed-off-by: Shawn J. Goff <shawn7400@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libcurl')
-rw-r--r--package/libcurl/libcurl.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index a631953af..f0236d97f 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -27,7 +27,9 @@ LIBCURL_CONF_ENV += ac_cv_lib_crypto_CRYPTO_lock=yes
# Fix it by setting LD_LIBRARY_PATH to something sensible so those libs
# are found first.
LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:/lib:/usr/lib
-LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr --with-random=/dev/urandom
+LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr \
+ --with-random=/dev/urandom \
+ --with-ca-path=/etc/ssl/certs
else
LIBCURL_CONF_OPT += --without-ssl
endif