summaryrefslogtreecommitdiffstats
path: root/package/libconfig
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-09-01 10:51:31 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-09-01 10:51:31 +0000
commit467403dd1c3d15311d0f0b48dcc5cafd68c6a922 (patch)
tree666596be058dd16ae78dd20e3f26ee93814d2a8c /package/libconfig
parent6c15ea38d150fed815fd5cd2db29bedb60cb1c9a (diff)
downloadbuildroot-novena-467403dd1c3d15311d0f0b48dcc5cafd68c6a922.tar.gz
buildroot-novena-467403dd1c3d15311d0f0b48dcc5cafd68c6a922.zip
package: add libconfig package
Diffstat (limited to 'package/libconfig')
-rw-r--r--package/libconfig/Config.in9
-rw-r--r--package/libconfig/libconfig.mk20
2 files changed, 29 insertions, 0 deletions
diff --git a/package/libconfig/Config.in b/package/libconfig/Config.in
new file mode 100644
index 000000000..75dacab36
--- /dev/null
+++ b/package/libconfig/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBCONFIG
+ bool "libconfig"
+ help
+ Libconfig is a simple library for manipulating structured
+ configuration files. The file format is more compact and more
+ readable than XML. And unlike XML, it is type-aware, so it is
+ not necessary to do string parsing in application code.
+
+ http://www.hyperrealm.com/libconfig/
diff --git a/package/libconfig/libconfig.mk b/package/libconfig/libconfig.mk
new file mode 100644
index 000000000..8e7ef0b5c
--- /dev/null
+++ b/package/libconfig/libconfig.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# libconfig
+#
+#############################################################
+LIBCONFIG_VERSION:=1.3
+LIBCONFIG_SOURCE:=libconfig-$(LIBCONFIG_VERSION).tar.gz
+LIBCONFIG_SITE:=http://www.hyperrealm.com/libconfig/
+LIBCONFIG_AUTORECONF:=NO
+LIBCONFIG_INSTALL_STAGING:=YES
+LIBCONFIG_INSTALL_TARGET:=YES
+LIBCONFIG_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) install-strip
+
+ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
+LIBCONFIG_CONF_OPT:=--disable-cxx
+endif
+
+LIBCONFIG_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,libconfig))