summaryrefslogtreecommitdiffstats
path: root/package/libart
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-04-11 11:31:40 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-04-11 11:31:40 +0000
commitab36f50a82bdd99b4eb8a31ae1274af860619670 (patch)
tree7b1018a364f350861a905df0d81afe49385c39ec /package/libart
parent8eb01e4a051d7f67213706e8c386b54aa38ddb95 (diff)
downloadbuildroot-novena-ab36f50a82bdd99b4eb8a31ae1274af860619670.tar.gz
buildroot-novena-ab36f50a82bdd99b4eb8a31ae1274af860619670.zip
buildroot: add libart package
Diffstat (limited to 'package/libart')
-rw-r--r--package/libart/Config.in15
-rw-r--r--package/libart/libart-art-config-cross.patch34
-rw-r--r--package/libart/libart.mk20
3 files changed, 69 insertions, 0 deletions
diff --git a/package/libart/Config.in b/package/libart/Config.in
new file mode 100644
index 000000000..415be09e6
--- /dev/null
+++ b/package/libart/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_LIBART
+ bool "libart"
+ default n
+ help
+ Libart is a library for high-performance 2D graphics. It
+ supports a very powerful imaging model, basically the same
+ as SVG and the Java 2D API. It includes all PostScript
+ imaging operations, and adds antialiasing and
+ alpha-transparency. It is also highly tuned for incremental
+ rendering. It contains data structures and algorithms suited
+ to rapid, precise computation of Region of Interest, and a
+ two-phase rendering pipeline optimized for interactive
+ display.
+
+ http://www.levien.com/libart/
diff --git a/package/libart/libart-art-config-cross.patch b/package/libart/libart-art-config-cross.patch
new file mode 100644
index 000000000..4cf768014
--- /dev/null
+++ b/package/libart/libart-art-config-cross.patch
@@ -0,0 +1,34 @@
+diff -urpN libart_lgpl-2.3.20.orig/art_config.h libart_lgpl-2.3.20/art_config.h
+--- libart_lgpl-2.3.20.orig/art_config.h 2008-04-11 10:50:04.000000000 +0200
++++ libart_lgpl-2.3.20/art_config.h 2008-04-11 10:51:32.000000000 +0200
+@@ -1,9 +1,15 @@
+ /* Automatically generated by gen_art_config.c */
+
++#include <limits.h>
++
+ #define ART_SIZEOF_CHAR 1
+ #define ART_SIZEOF_SHORT 2
+ #define ART_SIZEOF_INT 4
++#if LONG_MAX == 2147483647L
+ #define ART_SIZEOF_LONG 4
++#else
++#define ART_SIZEOF_LONG 8
++#endif
+
+ typedef unsigned char art_u8;
+ typedef unsigned short art_u16;
+diff -urpN libart_lgpl-2.3.20.orig/Makefile.am libart_lgpl-2.3.20/Makefile.am
+--- libart_lgpl-2.3.20.orig/Makefile.am 2008-04-11 10:50:04.000000000 +0200
++++ libart_lgpl-2.3.20/Makefile.am 2008-04-11 10:50:31.000000000 +0200
+@@ -3,11 +3,6 @@ noinst_PROGRAMS = testart testuta gen_ar
+ bin_SCRIPTS = \
+ libart2-config
+
+-BUILT_SOURCES = art_config.h
+-
+-art_config.h: gen_art_config$(EXEEXT)
+- ./gen_art_config > art_config.h
+-
+ EXTRA_DIST = \
+ libart.def \
+ libart-config.in \
diff --git a/package/libart/libart.mk b/package/libart/libart.mk
new file mode 100644
index 000000000..18577684e
--- /dev/null
+++ b/package/libart/libart.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# libart
+#
+#############################################################
+
+LIBART_VERSION = 2.3.20
+LIBART_SOURCE = libart_lgpl-$(LIBART_VERSION).tar.gz
+LIBART_SITE = http://ftp.gnome.org/pub/gnome/sources/libart_lgpl/2.3/
+LIBART_AUTORECONF = YES
+LIBART_STAGING = YES
+LIBART_TARGET = YES
+
+LIBART_CONF_OPT = --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) --build=$(GNU_HOST_NAME) \
+ --prefix=/usr --sysconfdir=/etc
+
+LIBART_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,libart))