summaryrefslogtreecommitdiffstats
path: root/package/libarchive
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-10-20 22:31:48 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-20 22:37:49 +0200
commit683a964c8f6bcf2b1ecc58460661e9d3bb98908b (patch)
tree8081921e42e86717ae177b981551f602655c1718 /package/libarchive
parentd7f5f04ba24d9315651900b9c9273463bf8dc1fa (diff)
downloadbuildroot-novena-683a964c8f6bcf2b1ecc58460661e9d3bb98908b.tar.gz
buildroot-novena-683a964c8f6bcf2b1ecc58460661e9d3bb98908b.zip
libarchive: make bsdtar and bsdcpio binaries configurable
libarchive comes with two binaries, bsdtar and bsdcpio that used to be installed by default. This change makes this configurable with the default not to build and install the binaries. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libarchive')
-rw-r--r--package/libarchive/Config.in15
-rw-r--r--package/libarchive/libarchive.mk4
2 files changed, 19 insertions, 0 deletions
diff --git a/package/libarchive/Config.in b/package/libarchive/Config.in
index 9154861c0..38928b00f 100644
--- a/package/libarchive/Config.in
+++ b/package/libarchive/Config.in
@@ -9,3 +9,18 @@ config BR2_PACKAGE_LIBARCHIVE
comment "libarchive requires a toolchain with WCHAR support"
depends on !BR2_USE_WCHAR
+
+config BR2_PACKAGE_LIBARCHIVE_BSDTAR
+ bool "bsdtar"
+ depends on BR2_PACKAGE_LIBARCHIVE
+ help
+ The 'bsdtar' program is a full-featured 'tar'
+ replacement built on libarchive.
+
+config BR2_PACKAGE_LIBARCHIVE_BSDCPIO
+ bool "bsdcpio"
+ depends on BR2_PACKAGE_LIBARCHIVE
+ help
+ The 'bsdcpio' program is a different interface to
+ essentially the same functionality as 'bsdtar'.
+
diff --git a/package/libarchive/libarchive.mk b/package/libarchive/libarchive.mk
index 472e34bd4..32f68f740 100644
--- a/package/libarchive/libarchive.mk
+++ b/package/libarchive/libarchive.mk
@@ -10,4 +10,8 @@ LIBARCHIVE_LIBTOOL_PATCH = NO
LIBARCHIVE_INSTALL_STAGING = YES
LIBARCHIVE_INSTALL_TARGET = YES
+LIBARCHIVE_CONF_OPT = \
+ $(if $(BR2_PACKAGE_LIBARCHIVE_BSDTAR),--enable-bsdtar,--disable-bsdtar) \
+ $(if $(BR2_PACKAGE_LIBARCHIVE_BSDCPIO),--enable-bsdcpio,--disable-bsdcpio)
+
$(eval $(call AUTOTARGETS,package,libarchive))