summaryrefslogtreecommitdiffstats
path: root/package/less
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 23:50:19 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:26:52 +0200
commit0d5cf75df62825209e134841f0e82f205a0a8c87 (patch)
treee76023c3cb304ba1c142f87a261322bf464f12b3 /package/less
parentedf47fc62c129b5c45c443ae058f290d7cb7a013 (diff)
downloadbuildroot-novena-0d5cf75df62825209e134841f0e82f205a0a8c87.tar.gz
buildroot-novena-0d5cf75df62825209e134841f0e82f205a0a8c87.zip
less: use correct step override method
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/less')
-rw-r--r--package/less/less.mk17
1 files changed, 7 insertions, 10 deletions
diff --git a/package/less/less.mk b/package/less/less.mk
index bae1cf654..6f985ed94 100644
--- a/package/less/less.mk
+++ b/package/less/less.mk
@@ -8,15 +8,12 @@ LESS_VERSION = 436
LESS_SITE = http://www.greenwoodsoftware.com/less
LESS_DEPENDENCIES = ncurses
-$(eval $(call AUTOTARGETS,package,less))
-
-$(LESS_TARGET_INSTALL_TARGET):
- $(call MESSAGE,"Installing to target")
- $(INSTALL) -m 0755 $(LESS_DIR)/less \
- $(TARGET_DIR)/usr/bin/less
- touch $@
+define LESS_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 $(@D)/less $(TARGET_DIR)/usr/bin/less
+endef
-$(LESS_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define LESS_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/bin/less
- rm -f $(LESS_TARGET_INSTALL_TARGET) $(LESS_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,less))