summaryrefslogtreecommitdiffstats
path: root/package/lcdproc
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-11-25 05:52:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-26 10:16:23 -0800
commit3bdbe9abb90de0262832d5d545f239fa41fb0e91 (patch)
tree124f3fdc94bb538f0a57c1935daa8608a66603dd /package/lcdproc
parentade0a8a856e1009210538170cd72d92a07c06233 (diff)
downloadbuildroot-novena-3bdbe9abb90de0262832d5d545f239fa41fb0e91.tar.gz
buildroot-novena-3bdbe9abb90de0262832d5d545f239fa41fb0e91.zip
lcdproc: fix autobuild errors
The autobuilders are falling over building lcdproc, with failures like the following. http://autobuild.buildroot.net/results/622b7da10be751c725ba25eb40102269790b4b03/build-end.log As Thomas Petazzoni has pointed out, the compile command lines incorrectly contain host header and library search paths, such as the following. -I/home/peko/scratch/host/usr/include/freetype2 -L/home/peko/scratch/host/usr/lib -lfreetype This patch changes the lcdproc package to pass the freetype installation prefixes on the configure command line. Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lcdproc')
-rw-r--r--package/lcdproc/lcdproc.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/lcdproc/lcdproc.mk b/package/lcdproc/lcdproc.mk
index 2a80289e3..fe88f46f0 100644
--- a/package/lcdproc/lcdproc.mk
+++ b/package/lcdproc/lcdproc.mk
@@ -10,7 +10,9 @@ LCDPROC_LICENSE = GPLv2+
LCDPROC_LICENSE_FILES = COPYING
LCDPROC_MAKE = $(MAKE1)
-LCDPROC_CONF_OPT = --enable-drivers=$(BR2_PACKAGE_LCDPROC_DRIVERS)
+LCDPROC_CONF_OPT = --enable-drivers=$(BR2_PACKAGE_LCDPROC_DRIVERS) \
+ --with-ft-prefix="$(STAGING_DIR)/usr" \
+ --with-ft-exec-prefix="$(STAGING_DIR)/usr"
ifeq ($(BR2_PACKAGE_LCDPROC_MENUS),y)
LCDPROC_CONF_OPT += --enable-lcdproc-menus