summaryrefslogtreecommitdiffstats
path: root/package/latencytop
diff options
context:
space:
mode:
authorQais Yousef <Qais.Yousef@imgtec.com>2012-04-18 01:06:00 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-24 23:26:56 +0200
commitcd2f78b1c5af76cfc14ad2227d6627b24367fb50 (patch)
tree73c0a1031308a99af35b0b784ced7859824a0138 /package/latencytop
parent94c297c4488ced4f580dd036a42f6718f072e57a (diff)
downloadbuildroot-novena-cd2f78b1c5af76cfc14ad2227d6627b24367fb50.tar.gz
buildroot-novena-cd2f78b1c5af76cfc14ad2227d6627b24367fb50.zip
New Package: latencytop
[Peter: fix Config.in location] Signed-off-by: Qais Yousef <qais.yousef@imgtec.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/latencytop')
-rw-r--r--package/latencytop/Config.in23
-rw-r--r--package/latencytop/latencytop-makefile.patch28
-rw-r--r--package/latencytop/latencytop.mk21
3 files changed, 72 insertions, 0 deletions
diff --git a/package/latencytop/Config.in b/package/latencytop/Config.in
new file mode 100644
index 000000000..12176c0cb
--- /dev/null
+++ b/package/latencytop/Config.in
@@ -0,0 +1,23 @@
+config BR2_PACKAGE_LATENCYTOP
+ bool "latencytop"
+ depends on BR2_USE_WCHAR
+ select BR2_PACKAGE_NCURSES
+ select BR2_PACKAGE_LIBGLIB2
+ help
+ There are many types and causes of latency. LatencyTOP
+ focuses on the type of latency that causes skips in audio,
+ stutters in your desktop experience or that overloads your
+ server (while you have plenty of CPU power left).
+
+ LatencyTOP focuses on the cases where the applications want
+ to run and execute useful code, but there's some resource
+ that's not currently available (and the kernel then blocks
+ the process). This is done both on a system level and on a
+ per process level, so that you can see what's happening to
+ the system, and which process is suffering and/or causing
+ the delays.
+
+ http://www.latencytop.org
+
+comment "latencytop requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
diff --git a/package/latencytop/latencytop-makefile.patch b/package/latencytop/latencytop-makefile.patch
new file mode 100644
index 000000000..fa8c51cfd
--- /dev/null
+++ b/package/latencytop/latencytop-makefile.patch
@@ -0,0 +1,28 @@
+Usee $(CC) to enable cross compiling and link to the right ncurses library.
+
+Signed-off-by: Qais Yousef <qais.yousef@imgtec.com>
+
+--- latencytop-0.5/Makefile.old 2012-04-18 11:59:39.748084334 +0100
++++ latencytop-0.5/Makefile 2012-04-18 12:00:08.659112340 +0100
+@@ -4,7 +4,7 @@
+ DESTDIR =
+ SBINDIR = /usr/sbin
+ XCFLAGS = -W -g `pkg-config --cflags glib-2.0` -D_FORTIFY_SOURCE=2 -Wno-sign-compare
+-LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncursesw
++LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncurses
+
+ OBJS= latencytop.o text_display.o translate.o fsync.o
+
+@@ -26,10 +26,10 @@
+
+ # We write explicity this "implicit rule"
+ %.o : %.c
+- gcc -c $(CFLAGS) $(XCFLAGS) $< -o $@
++ $(CC) -c $(CFLAGS) $(XCFLAGS) $< -o $@
+
+ latencytop: $(OBJS) latencytop.h Makefile
+- gcc $(CFLAGS) $(OBJS) $(LDF) -o latencytop
++ $(CC) $(CFLAGS) $(OBJS) $(LDF) -o latencytop
+
+ clean:
+ rm -f *~ latencytop DEADJOE *.o
diff --git a/package/latencytop/latencytop.mk b/package/latencytop/latencytop.mk
new file mode 100644
index 000000000..73d5ba219
--- /dev/null
+++ b/package/latencytop/latencytop.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# latencytop
+#
+#############################################################
+
+LATENCYTOP_VERSION = 0.5
+LATENCYTOP_SITE = http://www.latencytop.org/download/
+LATENCYTOP_DEPENDENCIES = libglib2 ncurses
+
+# NOTE: GTK is heavy weight, we intentionally build the text (ncurses)
+# version only
+define LATENCYTOP_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) HAS_GTK_GUI=
+endef
+
+define LATENCYTOP_INSTALL_TARGET_CMDS
+ $(MAKE) install -C $(@D) DESTDIR=$(TARGET_DIR) HAS_GTK_GUI=
+endef
+
+$(eval $(call GENTARGETS))