summaryrefslogtreecommitdiffstats
path: root/package/kismet
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-04-11 23:49:41 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-12 11:56:04 +0200
commit6d916b73ce84430ec9c0ee1a61b8d85f59ed8f37 (patch)
tree689ca2a6dbb33c0a73300fd3493b77d1c5809fcb /package/kismet
parent13e2c9e7b0e9b02828a4d6d54ae3a40ef17046df (diff)
downloadbuildroot-novena-6d916b73ce84430ec9c0ee1a61b8d85f59ed8f37.tar.gz
buildroot-novena-6d916b73ce84430ec9c0ee1a61b8d85f59ed8f37.zip
kismet: bump to version 2013-03-R1b
Fixes issues in the configure script. Also make libnl a mandatory dependency to fix: http://autobuild.buildroot.net/results/c8bf63f4ee013bd3467934c87c61478a1f95e3eb/ Kismet isn't too useful without it anyway. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/kismet')
-rw-r--r--package/kismet/Config.in6
-rw-r--r--package/kismet/kismet.mk9
2 files changed, 7 insertions, 8 deletions
diff --git a/package/kismet/Config.in b/package/kismet/Config.in
index 695466542..8de29beea 100644
--- a/package/kismet/Config.in
+++ b/package/kismet/Config.in
@@ -1,12 +1,14 @@
-comment "Kismet requires a toolchain with C++ support enabled"
- depends on !BR2_INSTALL_LIBSTDCPP
+comment "Kismet requires a toolchain with thread and C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
config BR2_PACKAGE_KISMET
bool "kismet"
depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libnl
select BR2_PACKAGE_NCURSES
select BR2_PACKAGE_NCURSES_TARGET_PANEL
select BR2_PACKAGE_LIBPCAP
+ select BR2_PACKAGE_LIBNL
help
Kismet - 802.11 layer2 wireless network detector, sniffer,
and intrusion detection system.
diff --git a/package/kismet/kismet.mk b/package/kismet/kismet.mk
index 5abc92c14..1fb3f5a29 100644
--- a/package/kismet/kismet.mk
+++ b/package/kismet/kismet.mk
@@ -4,16 +4,13 @@
#
#############################################################
-KISMET_VERSION = 2013-03-R1a
+KISMET_VERSION = 2013-03-R1b
KISMET_SITE = http://www.kismetwireless.net/code
-KISMET_DEPENDENCIES = host-pkgconf libpcap ncurses
+KISMET_DEPENDENCIES = host-pkgconf libpcap ncurses libnl
+KISMET_CONF_OPT += --with-netlink-version=3
KISMET_LICENSE = GPLv2+
KISMET_LICENSE_FILES = debian/copyright
-ifeq ($(BR2_PACKAGE_LIBNL),y)
- KISMET_DEPENDENCIES += libnl
- KISMET_CONF_OPT += --with-netlink-version=3
-endif
ifeq ($(BR2_PACKAGE_PCRE),y)
KISMET_DEPENDENCIES += pcre
endif