summaryrefslogtreecommitdiffstats
path: root/package/keyutils/keyutils-04-Makefile-for-buildroot.patch
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-16 06:56:20 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-16 21:39:50 +0100
commit90934a3de8364038b05d33b8145fd6d506809a64 (patch)
tree786b8cce2b38aeb20826da79889ebb65e26d492c /package/keyutils/keyutils-04-Makefile-for-buildroot.patch
parentfd303038febaf7008a1f04262dc5decb32d1cfab (diff)
downloadbuildroot-novena-90934a3de8364038b05d33b8145fd6d506809a64.tar.gz
buildroot-novena-90934a3de8364038b05d33b8145fd6d506809a64.zip
package/keyutils: new package
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Jarkko Sakkinen <jarkko.sakkinen@iki.fi> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/keyutils/keyutils-04-Makefile-for-buildroot.patch')
-rw-r--r--package/keyutils/keyutils-04-Makefile-for-buildroot.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/package/keyutils/keyutils-04-Makefile-for-buildroot.patch b/package/keyutils/keyutils-04-Makefile-for-buildroot.patch
new file mode 100644
index 000000000..e10abd55c
--- /dev/null
+++ b/package/keyutils/keyutils-04-Makefile-for-buildroot.patch
@@ -0,0 +1,65 @@
+diff -durN keyutils-1.5.5.orig/Makefile keyutils-1.5.5/Makefile
+--- keyutils-1.5.5.orig/Makefile 2011-11-30 16:27:43.000000000 +0100
++++ keyutils-1.5.5/Makefile 2012-08-14 17:06:07.064412101 +0200
+@@ -1,7 +1,5 @@
+-CPPFLAGS := -I.
+-CFLAGS := -g -Wall -Werror
+-INSTALL := install
+-DESTDIR :=
++CPPFLAGS += -I.
++CFLAGS += -g -Wall -Werror
+ SPECFILE := keyutils.spec
+ NO_GLIBC_KEYERR := 0
+ NO_ARLIB := 0
+@@ -14,7 +12,7 @@
+ MAN5 := /usr/share/man/man5
+ MAN8 := /usr/share/man/man8
+ INCLUDEDIR := /usr/include
+-LNS := ln -sf
++LNS := $(LN) -sf
+
+ ###############################################################################
+ #
+@@ -48,29 +46,6 @@
+
+ ###############################################################################
+ #
+-# Guess at the appropriate lib directory and word size
+-#
+-###############################################################################
+-LIBDIR := $(shell ldd /usr/bin/make | grep '\(/libc\)' | sed -e 's!.*\(/.*\)/libc[.].*!\1!')
+-USRLIBDIR := $(patsubst /lib/%,/usr/lib/%,$(LIBDIR))
+-BUILDFOR := $(shell file /usr/bin/make | sed -e 's!.*ELF \(32\|64\)-bit.*!\1!')-bit
+-
+-LNS := ln -sf
+-
+-ifeq ($(BUILDFOR),32-bit)
+-CFLAGS += -m32
+-LIBDIR := /lib
+-USRLIBDIR := /usr/lib
+-else
+-ifeq ($(BUILDFOR),64-bit)
+-CFLAGS += -m64
+-LIBDIR := /lib64
+-USRLIBDIR := /usr/lib64
+-endif
+-endif
+-
+-###############################################################################
+-#
+ # This is necessary if glibc doesn't know about the key management error codes
+ #
+ ###############################################################################
+@@ -110,10 +85,10 @@
+
+
+ $(DEVELLIB): $(SONAME)
+- ln -sf $< $@
++ $(LNS) $< $@
+
+ $(SONAME): $(LIBNAME)
+- ln -sf $< $@
++ $(LNS) $< $@
+
+ LIBVERS := -shared -Wl,-soname,$(SONAME) -Wl,--version-script,version.lds
+