summaryrefslogtreecommitdiffstats
path: root/package/kexec
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2011-09-26 14:31:17 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-26 22:16:08 +0200
commitb766ed21e8b5499dd2237d80358229de04ddab9a (patch)
treeae9918428fb4cc64b09d7467ac58c59b426123fb /package/kexec
parentfd68d696eacbb7b8363be1948365957a641041a8 (diff)
downloadbuildroot-novena-b766ed21e8b5499dd2237d80358229de04ddab9a.tar.gz
buildroot-novena-b766ed21e8b5499dd2237d80358229de04ddab9a.zip
kexec: fix compilation with gcc 4.6
gcc 4.6 has stricter checks for invalid command-line options. Fix compilation by passing linker options with -Wl, Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/kexec')
-rw-r--r--package/kexec/kexec-fix-linker-options.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kexec/kexec-fix-linker-options.patch b/package/kexec/kexec-fix-linker-options.patch
new file mode 100644
index 000000000..7bd5f1d45
--- /dev/null
+++ b/package/kexec/kexec-fix-linker-options.patch
@@ -0,0 +1,15 @@
+Fix compilation with gcc 4.6 by correcting the way that linker options
+are passed to gcc.
+
+Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
+--- kexec-2.0.2/purgatory/Makefile.orig 2011-09-26 14:16:44.256595912 +0200
++++ kexec-2.0.2/purgatory/Makefile 2011-09-26 14:17:01.606621357 +0200
+@@ -56,7 +56,7 @@
+ -I$(srcdir)/include \
+ -I$(shell $(CC) -print-file-name=include)
+ $(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\
+- --no-undefined -nostartfiles -nostdlib -nodefaultlibs \
++ -Wl,-no-undefined -nostartfiles -nostdlib -nodefaultlibs \
+ -e purgatory_start -r
+
+ $(PURGATORY): $(PURGATORY_OBJS)