summaryrefslogtreecommitdiffstats
path: root/package/json-glib
diff options
context:
space:
mode:
authorHenrique Camargo <henrique@henriquecamargo.com>2013-02-18 11:29:03 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-18 22:00:02 +0100
commit0a2a3c9cd6a873a0ca190c9f20e9a42a9d1df58a (patch)
tree7393e36cc121d2d0222322fb248d6c477db6ef0e /package/json-glib
parent901282aa6e330c5e61ab25a83ba68e443cb3aec2 (diff)
downloadbuildroot-novena-0a2a3c9cd6a873a0ca190c9f20e9a42a9d1df58a.tar.gz
buildroot-novena-0a2a3c9cd6a873a0ca190c9f20e9a42a9d1df58a.zip
json-glib: new package
JSON-GLib is a library providing serialization and deserialization support for the JavaScript Object Notation (JSON) format described by RFC 4627. https://live.gnome.org/JsonGlib/ [Peter: add license info, tweak help text] Signed-off-by: Henrique Camargo <henrique@henriquecamargo.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/json-glib')
-rw-r--r--package/json-glib/Config.in14
-rw-r--r--package/json-glib/json-glib.mk21
2 files changed, 35 insertions, 0 deletions
diff --git a/package/json-glib/Config.in b/package/json-glib/Config.in
new file mode 100644
index 000000000..3ebc76db2
--- /dev/null
+++ b/package/json-glib/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_JSON_GLIB
+ bool "json-glib"
+ depends on BR2_USE_WCHAR # glib2
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
+ help
+ JSON-GLib is a library providing serialization and
+ deserialization support for the JavaScript Object Notation
+ (JSON) format described by RFC 4627.
+
+ https://live.gnome.org/JsonGlib/
+
+comment "json-glib requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
diff --git a/package/json-glib/json-glib.mk b/package/json-glib/json-glib.mk
new file mode 100644
index 000000000..4e3f987bc
--- /dev/null
+++ b/package/json-glib/json-glib.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# json-glib
+#
+#############################################################
+
+JSON_GLIB_MAJOR_VERSION = 0.14
+JSON_GLIB_MINOR_VERSION = 2
+JSON_GLIB_VERSION = $(JSON_GLIB_MAJOR_VERSION).$(JSON_GLIB_MINOR_VERSION)
+JSON_GLIB_SITE = http://ftp.gnome.org/pub/GNOME/sources/json-glib/$(JSON_GLIB_MAJOR_VERSION)
+JSON_GLIB_SOURCE = json-glib-$(JSON_GLIB_VERSION).tar.xz
+JSON_GLIB_LICENSE = LGPLv2.1+
+JSON_GLIB_LICENSE_FILES = COPYING
+JSON_GLIB_INSTALL_STAGING = YES
+
+JSON_GLIB_DEPENDENCIES = \
+ $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) \
+ host-pkgconf \
+ libglib2
+
+$(eval $(autotools-package))