summaryrefslogtreecommitdiffstats
path: root/package/json-c
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-08-25 16:13:12 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-06 23:32:33 +0200
commit58149528d09b3342477beb3f5abce83775acdaff (patch)
treec95ad99493c69fb1ad7e998bfcd71f477c2d6ba7 /package/json-c
parentd6743630d25e3e8f483ead766224444ff24965b5 (diff)
downloadbuildroot-novena-58149528d09b3342477beb3f5abce83775acdaff.tar.gz
buildroot-novena-58149528d09b3342477beb3f5abce83775acdaff.zip
json-c: fix build when no thread support is available
Fixes http://autobuild.buildroot.org/results/1d9a2e44da3aa627265b03763ca324c609c0c61c/build-end.log. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/json-c')
-rw-r--r--package/json-c/json-c-no-reentrant.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/package/json-c/json-c-no-reentrant.patch b/package/json-c/json-c-no-reentrant.patch
new file mode 100644
index 000000000..a01181cfb
--- /dev/null
+++ b/package/json-c/json-c-no-reentrant.patch
@@ -0,0 +1,33 @@
+Do not pass -D_REENTRANT
+
+This flag is not needed to build this library, and prevents to build
+it with toolchains that don't have thread support.
+
+Since the Makefile.in change is a one-liner, we also do it in the
+patch to avoid having to autoreconfigure the package.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile.am
+===================================================================
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
++AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
+
+ EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc
+
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -219,7 +219,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
++AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
+ EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc
+ lib_LTLIBRARIES = libjson.la
+ pkgconfigdir = $(libdir)/pkgconfig