summaryrefslogtreecommitdiffstats
path: root/package/jquery-ui-themes
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-06-14 10:02:12 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-06 23:46:10 +0200
commit77572e6f9fa116562f050b3d1c255ba0010e8ff0 (patch)
treec2b795ac932f979260c560a290215ff10e14d5ef /package/jquery-ui-themes
parent0421f606f0f3479ea87a302ccc601627067282ba (diff)
downloadbuildroot-novena-77572e6f9fa116562f050b3d1c255ba0010e8ff0.tar.gz
buildroot-novena-77572e6f9fa116562f050b3d1c255ba0010e8ff0.zip
jquery-ui-themes: new package
[Peter: drop CSS path option, depend on jquery-ui, misc cleanups] Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/jquery-ui-themes')
-rw-r--r--package/jquery-ui-themes/Config.in14
-rw-r--r--package/jquery-ui-themes/jquery-ui-themes.mk32
2 files changed, 46 insertions, 0 deletions
diff --git a/package/jquery-ui-themes/Config.in b/package/jquery-ui-themes/Config.in
new file mode 100644
index 000000000..dfde9c193
--- /dev/null
+++ b/package/jquery-ui-themes/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_JQUERY_UI_THEMES
+ bool "jQuery UI themes"
+ depends on BR2_PACKAGE_JQUERY_UI
+ help
+ Themes for jQuery UI.
+
+ http://jqueryui.com/
+
+config BR2_PACKAGE_JQUERY_UI_THEMES_THEME
+ string "theme to install"
+ default "base"
+ depends on BR2_PACKAGE_JQUERY_UI_THEMES
+ help
+ Specify the name of the jQuery UI theme to install.
diff --git a/package/jquery-ui-themes/jquery-ui-themes.mk b/package/jquery-ui-themes/jquery-ui-themes.mk
new file mode 100644
index 000000000..ae50ad41b
--- /dev/null
+++ b/package/jquery-ui-themes/jquery-ui-themes.mk
@@ -0,0 +1,32 @@
+#############################################################
+#
+# jquery-ui-themes
+#
+#############################################################
+
+JQUERY_UI_THEMES_VERSION = 1.8.21
+JQUERY_UI_THEMES_SITE = http://jquery-ui.googlecode.com/files
+JQUERY_UI_THEMES_SOURCE = jquery-ui-themes-$(JQUERY_UI_THEMES_VERSION).zip
+JQUERY_UI_THEMES_DEPENDENCIES = jquery-ui
+
+define JQUERY_UI_THEMES_EXTRACT_CMDS
+ unzip -d $(@D) $(DL_DIR)/$(JQUERY_UI_THEMES_SOURCE)
+ mv $(@D)/jquery-ui-themes-$(JQUERY_UI_THEMES_VERSION)/* $(@D)
+ $(RM) -r $(@D)/jquery-ui-themes-$(JQUERY_UI_THEMES_VERSION)
+endef
+
+define JQUERY_UI_THEMES_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0644 -D \
+ $(@D)/themes/$(BR2_PACKAGE_JQUERY_UI_THEMES_THEME)/jquery-ui.css \
+ $(TARGET_DIR)/var/www/jquery-ui.css
+ $(INSTALL) -d $(TARGET_DIR)/var/www/images
+ cp -a $(@D)/themes/$(BR2_PACKAGE_JQUERY_UI_THEMES_THEME)/images/*.png \
+ $(TARGET_DIR)/var/www/images
+ chmod 0644 $(TARGET_DIR)/var/www/images/*.png
+endef
+
+define JQUERY_UI_THEMES_UNINSTALL_TARGET_CMDS
+ $(RM) $(TARGET_DIR)/var/www/jquery-ui.css
+endef
+
+$(eval $(generic-package))