summaryrefslogtreecommitdiffstats
path: root/package/jpeg
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-28 12:41:56 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-28 12:41:56 +0000
commit080026489c01dd1fe8b796f59cee8f2fb9f7182c (patch)
tree93379479ca53327b41f504d339c4218e2d3319c9 /package/jpeg
parent4427e87559a5a666b1e4dbd1a63c10c74397a14b (diff)
downloadbuildroot-novena-080026489c01dd1fe8b796f59cee8f2fb9f7182c.tar.gz
buildroot-novena-080026489c01dd1fe8b796f59cee8f2fb9f7182c.zip
- use correct include dir (Simon Pasch)
- cleanup while at it
Diffstat (limited to 'package/jpeg')
-rw-r--r--package/jpeg/jpeg.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/jpeg/jpeg.mk b/package/jpeg/jpeg.mk
index 23ed458ab..eec158773 100644
--- a/package/jpeg/jpeg.mk
+++ b/package/jpeg/jpeg.mk
@@ -35,7 +35,7 @@ $(JPEG_DIR)/.unpacked: $(DL_DIR)/$(JPEG_SOURCE)
$(JPEG_CAT) $(DL_DIR)/$(JPEG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(JPEG_DIR) package/jpeg/ jpeg\*.patch
$(CONFIG_UPDATE) $(JPEG_DIR)
- touch $(JPEG_DIR)/.unpacked
+ touch $@
$(JPEG_DIR)/.configured: $(JPEG_DIR)/.unpacked
(cd $(JPEG_DIR); rm -rf config.cache; \
@@ -54,28 +54,28 @@ $(JPEG_DIR)/.configured: $(JPEG_DIR)/.unpacked
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
- --includedir=/include \
+ --includedir=/usr/include \
--mandir=/usr/man \
--infodir=/usr/info \
--enable-shared \
--enable-static \
--without-x \
)
- touch $(JPEG_DIR)/.configured
+ touch $@
$(JPEG_DIR)/.libs/libjpeg.a: $(JPEG_DIR)/.configured
$(MAKE) -C $(JPEG_DIR) all
- touch -c $(JPEG_DIR)/.libs/libjpeg.a
+ touch -c $@
$(STAGING_DIR)/lib/libjpeg.a: $(JPEG_DIR)/.libs/libjpeg.a
$(MAKE) DESTDIR=$(STAGING_DIR) -C $(JPEG_DIR) install-headers install-lib
rm $(STAGING_DIR)/lib/libjpeg.la
- touch -c $(STAGING_DIR)/lib/libjpeg.a
+ touch -c $@
$(TARGET_DIR)/usr/lib/libjpeg.so: $(STAGING_DIR)/lib/libjpeg.a
cp -dpf $(STAGING_DIR)/lib/libjpeg.so* $(TARGET_DIR)/usr/lib/
-$(STRIP) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libjpeg.so*
- touch -c $(TARGET_DIR)/usr/lib/libjpeg.so
+ touch -c $@
jpeg: uclibc $(TARGET_DIR)/usr/lib/libjpeg.so