summaryrefslogtreecommitdiffstats
path: root/package/iw
diff options
context:
space:
mode:
authorYegor Yefremov <yegor_sub1@visionsystems.de>2011-04-28 09:23:51 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-15 00:09:05 +0200
commit644d8808d274018a2cc67b35b781dff64d66d3a6 (patch)
tree4c987f61f558f89f30e1ec0521e034aef387ee4a /package/iw
parentfec53c73cf64106bf7f9d3ec6eb518f08479c6b7 (diff)
downloadbuildroot-novena-644d8808d274018a2cc67b35b781dff64d66d3a6.tar.gz
buildroot-novena-644d8808d274018a2cc67b35b781dff64d66d3a6.zip
iw: add support for libnl-3.0
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/iw')
-rw-r--r--package/iw/iw-libnl-30-support.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/iw/iw-libnl-30-support.patch b/package/iw/iw-libnl-30-support.patch
new file mode 100644
index 000000000..48a179fb2
--- /dev/null
+++ b/package/iw/iw-libnl-30-support.patch
@@ -0,0 +1,47 @@
+---
+ Makefile | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -24,6 +24,7 @@
+
+ NL1FOUND := $(shell $(PKG_CONFIG) --atleast-version=1 libnl-1 && echo Y)
+ NL2FOUND := $(shell $(PKG_CONFIG) --atleast-version=2 libnl-2.0 && echo Y)
++NL3FOUND := $(shell $(PKG_CONFIG) --atleast-version=3 libnl-3.0 && echo Y)
+
+ ifeq ($(NL1FOUND),Y)
+ NLLIBNAME = libnl-1
+@@ -35,6 +36,12 @@
+ NLLIBNAME = libnl-2.0
+ endif
+
++ifeq ($(NL3FOUND),Y)
++CFLAGS += -DCONFIG_LIBNL20
++LIBS += -lnl-genl
++NLLIBNAME = libnl-3.0
++endif
++
+ ifeq ($(NLLIBNAME),)
+ $(error Cannot find development files for any supported version of libnl)
+ endif
+@@ -53,6 +60,8 @@
+ all: version_check $(ALL)
+
+ version_check:
++ifeq ($(NL3FOUND),Y)
++else
+ ifeq ($(NL2FOUND),Y)
+ else
+ ifeq ($(NL1FOUND),Y)
+@@ -60,6 +69,7 @@
+ $(error No libnl found)
+ endif
+ endif
++endif
+
+
+ VERSION_OBJS := $(filter-out version.o, $(OBJS))
+