summaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-09-18 11:08:27 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-09-18 11:08:27 +0000
commit9f8b1ce23d39d7f2e460297bbbd41e7beaac9d8e (patch)
tree3ca5262ffbd129a44c5329f1141748d8c31c5ead /package/iptables
parent3220405a75fb7b04ee9d496bf931f5b26bb3e8be (diff)
downloadbuildroot-novena-9f8b1ce23d39d7f2e460297bbbd41e7beaac9d8e.tar.gz
buildroot-novena-9f8b1ce23d39d7f2e460297bbbd41e7beaac9d8e.zip
iptables: fix install rule to install everything in appropriate directories
This patch will install iptables with the install-strip command, and also use /usr/lib as target for the filter libraries. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/iptables.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
index 43f02827a..5cc98e2a1 100644
--- a/package/iptables/iptables.mk
+++ b/package/iptables/iptables.mk
@@ -7,14 +7,13 @@ IPTABLES_VERSION = 1.4.1
IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
-IPTABLES_INSTALL_STAGING = NO
+IPTABLES_CONF_OPT = --libexecdir=/usr/lib
IPTABLES_INSTALL_TARGET = YES
-IPTABLES_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-exec-am
+IPTABLES_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-strip
IPTABLES_AUTORECONF = YES
-IPTABLES_DEPENDENCIES =
-IPTABLES_CONFIGURE_OPT = --with-kernel=$(LINUX_HEADERS_DIR)
+IPTABLES_DEPENDENCIES =
+IPTABLES_CONFIGURE_OPT = --with-kernel=$(LINUX_HEADERS_DIR)
IPTABLES_MAKE_OPT = GLIB_GENMARSHAL=/usr/bin/glib-genmarshal GLIB_MKENUMS=/usr/bin
$(eval $(call AUTOTARGETS,package,iptables))
-