summaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorOlaf Rempel <razzor@kopf-tisch.de>2009-09-20 13:54:02 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-09-20 14:44:12 +0200
commit1fe7bbb34df56d532e1057696bd73f081ca6c9bf (patch)
tree67949b17f16aacd0e5e8fa3d80dcecbef74638df /package/iptables
parent8e8354d4dbc6c3325881b840e77906e1d4cd0e1a (diff)
downloadbuildroot-novena-1fe7bbb34df56d532e1057696bd73f081ca6c9bf.tar.gz
buildroot-novena-1fe7bbb34df56d532e1057696bd73f081ca6c9bf.zip
iptables: fix disable-ipv6 option
- bumb version to v1.4.5 - add fix for --disable-ipv6 option (upstream bug: http://bugzilla.netfilter.org/show_bug.cgi?id=608) Signed-off-by: Olaf Rempel <razzor@kopf-tisch.de> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/iptables-1.4.5-disable-ipv6.patch19
-rw-r--r--package/iptables/iptables.mk2
2 files changed, 20 insertions, 1 deletions
diff --git a/package/iptables/iptables-1.4.5-disable-ipv6.patch b/package/iptables/iptables-1.4.5-disable-ipv6.patch
new file mode 100644
index 000000000..9f22a0c69
--- /dev/null
+++ b/package/iptables/iptables-1.4.5-disable-ipv6.patch
@@ -0,0 +1,19 @@
+--- iptables-1.4.5/xtables.c.org 2009-09-14 18:36:55.000000000 +0200
++++ iptables-1.4.5/xtables.c 2009-09-20 13:24:11.000000000 +0200
+@@ -1484,6 +1484,7 @@
+ xtables_ip6parse_multiple(const char *name, struct in6_addr **addrpp,
+ struct in6_addr **maskpp, unsigned int *naddrs)
+ {
++ static const struct in6_addr zero_addr;
+ struct in6_addr *addrp;
+ char buf[256], *p;
+ unsigned int len, i, j, n, count = 1;
+@@ -1526,7 +1527,7 @@
+ memcpy(*maskpp + i, addrp, sizeof(*addrp));
+
+ /* if a null mask is given, the name is ignored, like in "any/0" */
+- if (memcmp(*maskpp + i, &in6addr_any, sizeof(in6addr_any)) == 0)
++ if (memcmp(*maskpp + i, &zero_addr, sizeof(zero_addr)) == 0)
+ strcpy(buf, "::");
+
+ addrp = ip6parse_hostnetwork(buf, &n);
diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
index 48e5d3344..1c3d9bed9 100644
--- a/package/iptables/iptables.mk
+++ b/package/iptables/iptables.mk
@@ -3,7 +3,7 @@
# iptables
#
#############################################################
-IPTABLES_VERSION = 1.4.4
+IPTABLES_VERSION = 1.4.5
IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables