summaryrefslogtreecommitdiffstats
path: root/package/ipsec-tools/ipsec-tools.mk
diff options
context:
space:
mode:
authorWill Newton <will.newton@gmail.com>2009-06-22 12:21:38 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-06-23 09:33:24 +0200
commit7af9cd3ac58e881e1ecfa9836ec54f3458b13564 (patch)
tree2198afb31b100d4059517ca9c62678a6a95d3fa6 /package/ipsec-tools/ipsec-tools.mk
parent93308ccba3c743297d231f06a5a1fc0523d7e404 (diff)
downloadbuildroot-novena-7af9cd3ac58e881e1ecfa9836ec54f3458b13564.tar.gz
buildroot-novena-7af9cd3ac58e881e1ecfa9836ec54f3458b13564.zip
ipsec-tools: Bump version to 0.7.2.
Add support for configuring security context support to allow building for non-SELinux targets. Remove some obsolete patches. Signed-off-by: Will Newton <will.newton@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ipsec-tools/ipsec-tools.mk')
-rw-r--r--package/ipsec-tools/ipsec-tools.mk14
1 files changed, 12 insertions, 2 deletions
diff --git a/package/ipsec-tools/ipsec-tools.mk b/package/ipsec-tools/ipsec-tools.mk
index 2f67385c6..8190378b5 100644
--- a/package/ipsec-tools/ipsec-tools.mk
+++ b/package/ipsec-tools/ipsec-tools.mk
@@ -4,7 +4,7 @@
#
#############################################################
-IPSEC_TOOLS_VERSION:=0.6.7
+IPSEC_TOOLS_VERSION:=0.7.2
IPSEC_TOOLS_SOURCE:=ipsec-tools-$(IPSEC_TOOLS_VERSION).tar.bz2
IPSEC_TOOLS_CAT:=$(BZCAT)
IPSEC_TOOLS_DIR:=$(BUILD_DIR)/ipsec-tools-$(IPSEC_TOOLS_VERSION)
@@ -16,7 +16,7 @@ IPSEC_TOOLS_BINARY_RACOONCTL:=src/racoon/racoonctl
IPSEC_TOOLS_TARGET_BINARY_SETKEY:=usr/sbin/setkey
IPSEC_TOOLS_TARGET_BINARY_RACOON:=usr/sbin/racoon
IPSEC_TOOLS_TARGET_BINARY_RACOONCTL:=usr/sbin/racoonctl
-IPSEC_TOOLS_SITE=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/ipsec-tools/
+IPSEC_TOOLS_SITE=http://ftp.sunet.se/pub/NetBSD/misc/ipsec-tools/0.7/
ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_ADMINPORT), y)
IPSEC_TOOLS_CONFIG_FLAGS+= --enable-adminport
@@ -58,6 +58,16 @@ ifneq ($(BR2_PACKAGE_IPSEC_TOOLS_READLINE), y)
IPSEC_TOOLS_CONFIG_FLAGS+= --without-readline
endif
+ifeq ($(BR2_PACKAGE_IPSEC_SECCTX_DISABLE),y)
+IPSEC_TOOLS_CONFIG_FLAGS+= --enable-security-context=no
+endif
+ifeq ($(BR2_PACKAGE_IPSEC_SECCTX_ENABLE),y)
+IPSEC_TOOLS_CONFIG_FLAGS+= --enable-security-context=yes
+endif
+ifeq ($(BR2_PACKAGE_IPSEC_SECCTX_KERNEL),y)
+IPSEC_TOOLS_CONFIG_FLAGS+= --enable-security-context=kernel
+endif
+
$(DL_DIR)/$(IPSEC_TOOLS_SOURCE):
$(call DOWNLOAD,$(IPSEC_TOOLS_SITE),$(IPSEC_TOOLS_SOURCE))