summaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-23 22:26:36 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 13:44:32 +0100
commitfad8177bb33f2e7750efbd365d4431cabf7d0396 (patch)
tree363fdc5f17bf6e5cbacad98c2a2c79acc14d923d /package/iproute2
parent2f55f8e440ea6040ec7fc9ba0692dd0980a36bd9 (diff)
downloadbuildroot-novena-fad8177bb33f2e7750efbd365d4431cabf7d0396.tar.gz
buildroot-novena-fad8177bb33f2e7750efbd365d4431cabf7d0396.zip
iproute2: add dependency on host-bison
iproute2 requires bison, so we add the necessary dependency. In addition, in order for iproute2 to find bison, we need to pass $(TARGET_MAKE_ENV). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/iproute2.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index 7766ab870..98a7da078 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -10,6 +10,8 @@ IPROUTE2_TARGET_SBINS = ctstat genl ifstat ip lnstat nstat routef routel rtacct
IPROUTE2_LICENSE = GPLv2
IPROUTE2_LICENSE_FILES = COPYING
+IPROUTE2_DEPENDENCIES += host-bison
+
# If both iproute2 and busybox are selected, make certain we win
# the fight over who gets to have their utils actually installed.
ifeq ($(BR2_PACKAGE_BUSYBOX),y)
@@ -42,11 +44,12 @@ endef
define IPROUTE2_BUILD_CMDS
$(SED) 's/$$(CCOPTS)//' $(@D)/netem/Makefile
- $(MAKE) CC="$(TARGET_CC)" CCOPTS="$(TARGET_CFLAGS) -D_GNU_SOURCE" -C $(@D)
+ $(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" CCOPTS="$(TARGET_CFLAGS) -D_GNU_SOURCE" -C $(@D)
endef
define IPROUTE2_INSTALL_TARGET_CMDS
- $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" SBINDIR=/sbin \
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" \
+ SBINDIR=/sbin \
DOCDIR=/usr/share/doc/iproute2-$(IPROUTE2_VERSION) \
MANDIR=/usr/share/man install
# Wants bash