summaryrefslogtreecommitdiffstats
path: root/package/iproute2
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-01-10 14:41:25 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-11 00:20:34 +0100
commit749a5d7c2dd31118143c3038950c5e5e20243c39 (patch)
treed295bc037b40a9b5ed011a9594382a35fc3370d5 /package/iproute2
parentbd5cbcb2b1702fff9983f101b9bc4c96bcedc389 (diff)
downloadbuildroot-novena-749a5d7c2dd31118143c3038950c5e5e20243c39.tar.gz
buildroot-novena-749a5d7c2dd31118143c3038950c5e5e20243c39.zip
iproute2: bump to version 2.6.37 + fixes
Bump to version 2.6.37 Add iptables support when it's available. ATM support requires linux-atm for which we don't have a package yet. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/iproute2')
-rw-r--r--package/iproute2/iproute2.mk16
1 files changed, 13 insertions, 3 deletions
diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index 0f99894e5..c3e96509d 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -4,19 +4,29 @@
#
#############################################################
-IPROUTE2_VERSION = 2.6.35
+IPROUTE2_VERSION = 2.6.37
IPROUTE2_SOURCE = iproute2-$(IPROUTE2_VERSION).tar.bz2
IPROUTE2_SITE = http://devresources.linuxfoundation.org/dev/iproute2/download
IPROUTE2_TARGET_SBINS = ctstat genl ifstat ip lnstat nstat routef routel rtacct rtmon rtpr rtstat ss tc
+# If we've got iptables enable xtables support for tc
+ifeq ($(BR2_PACKAGE_IPTABLES),y)
+IPROUTE2_DEPENDENCIES += iptables
+define IPROUTE2_WITH_IPTABLES
+ # Makefile is busted so it never passes IPT_LIB_DIR properly
+ $(SED) "s/-DIPT/-DXT/" $(IPROUTE2_DIR)/tc/Makefile
+ echo "TC_CONFIG_XT:=y" >>$(IPROUTE2_DIR)/Config
+endef
+endif
+
define IPROUTE2_CONFIGURE_CMDS
# Use kernel headers
rm -r $(IPROUTE2_DIR)/include/netinet
# arpd needs berkeleydb
$(SED) "/^TARGETS=/s: arpd : :" $(IPROUTE2_DIR)/misc/Makefile
$(SED) "s:-O2:$(TARGET_CFLAGS):" $(IPROUTE2_DIR)/Makefile
- ( cd $(@D); ./configure )
- echo "IPT_LIB_DIR=/usr/lib/xtables" >>$(IPROUTE2_DIR)/Config
+ echo "IPT_LIB_DIR:=/usr/lib/xtables" >>$(IPROUTE2_DIR)/Config
+ $(IPROUTE2_WITH_IPTABLES)
endef
define IPROUTE2_BUILD_CMDS