summaryrefslogtreecommitdiffstats
path: root/package/iozone
diff options
context:
space:
mode:
authorgilles.talis@gmail.com <gilles.talis@gmail.com>2013-03-25 09:26:05 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-05 21:31:19 +0200
commitbaebf863ea11dbbcfea55a5877f4be0e85c1f37b (patch)
tree09b22469eaab3899c7e71f552130f18657b11fd6 /package/iozone
parent1ed86a07910dbd969390a23625d064256c4a694f (diff)
downloadbuildroot-novena-baebf863ea11dbbcfea55a5877f4be0e85c1f37b.tar.gz
buildroot-novena-baebf863ea11dbbcfea55a5877f4be0e85c1f37b.zip
IOzone: new package
[Peter: lower case package name, strip trailing newline] Signed-off-by: Gilles Talis <gilles.talis@gmail.com> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/iozone')
-rw-r--r--package/iozone/Config.in12
-rw-r--r--package/iozone/iozone.mk38
2 files changed, 50 insertions, 0 deletions
diff --git a/package/iozone/Config.in b/package/iozone/Config.in
new file mode 100644
index 000000000..5481ca15e
--- /dev/null
+++ b/package/iozone/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_IOZONE
+ bool "iozone"
+ depends on BR2_LARGEFILE
+ depends on BR2_USE_MMU # fork()
+ help
+ IOzone is a filesystem benchmark tool.
+ The benchmark generates and measures a variety of file operations
+
+ http://www.iozone.org/
+
+comment "IOzone requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/iozone/iozone.mk b/package/iozone/iozone.mk
new file mode 100644
index 000000000..71c6840fe
--- /dev/null
+++ b/package/iozone/iozone.mk
@@ -0,0 +1,38 @@
+#############################################################
+#
+# IOZONE
+#
+#############################################################
+
+IOZONE_VERSION = 3_414
+IOZONE_SOURCE = iozone$(IOZONE_VERSION).tar
+IOZONE_SITE = http://www.iozone.org/src/current
+IOZONE_LICENSE = IOzone license (NO DERIVED WORKS ALLOWED)
+# IOzone license details can be found at:
+# http://www.iozone.org/docs/Iozone_License.txt
+
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_CTNG_uClibc),y)
+# aio.h is not available on uClibc. Select "generic" target that does not use it.
+IOZONE_TARGET = generic
+else ifeq ($(BR2_powerpc),y)
+IOZONE_TARGET = linux-powerpc
+else ifeq ($(BR2_sparc),y)
+IOZONE_TARGET = linux-sparc
+else
+IOZONE_TARGET = linux
+endif
+
+define IOZONE_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) $(IOZONE_TARGET) -C $(@D)/src/current
+endef
+
+define IOZONE_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 755 $(@D)/src/current/iozone \
+ $(TARGET_DIR)/usr/bin/iozone
+endef
+
+define IOZONE_CLEAN_CMDS
+ $(MAKE) -C $(@D)/src/current clean
+endef
+
+$(eval $(generic-package))