summaryrefslogtreecommitdiffstats
path: root/package/iostat
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-09-30 20:41:41 +0000
committerEric Andersen <andersen@codepoet.org>2005-09-30 20:41:41 +0000
commitf2a5ce4b9da5940604061294b2414e6d163ffc7b (patch)
tree2ad774b7cc900b93e52c025daee97a9c6beaf23a /package/iostat
parent6628d4b2f68bdc61ac7e328c0d27b9affb43b4f0 (diff)
downloadbuildroot-novena-f2a5ce4b9da5940604061294b2414e6d163ffc7b.tar.gz
buildroot-novena-f2a5ce4b9da5940604061294b2414e6d163ffc7b.zip
Add iostat, ltt, xfsprogs, and memtester
Diffstat (limited to 'package/iostat')
-rw-r--r--package/iostat/Config.in7
-rw-r--r--package/iostat/iostat.mk46
-rw-r--r--package/iostat/iostat.patch11
3 files changed, 64 insertions, 0 deletions
diff --git a/package/iostat/Config.in b/package/iostat/Config.in
new file mode 100644
index 000000000..5c6697aa3
--- /dev/null
+++ b/package/iostat/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_IOSTAT
+ bool "iostat"
+ default n
+ help
+ An I/O performance monitoring utility.
+
+ http://linux.inet.hr/
diff --git a/package/iostat/iostat.mk b/package/iostat/iostat.mk
new file mode 100644
index 000000000..0c6042c37
--- /dev/null
+++ b/package/iostat/iostat.mk
@@ -0,0 +1,46 @@
+#############################################################
+#
+# iostat
+#
+#############################################################
+IOSTAT_VER:=2.2
+IOSTAT_SOURCE:=iostat-$(IOSTAT_VER).tar.gz
+IOSTAT_SITE:=http://linux.inet.hr
+IOSTAT_DIR:=$(BUILD_DIR)/iostat-$(IOSTAT_VER)
+IOSTAT_BINARY:=iostat
+IOSTAT_TARGET_BINARY:=usr/bin/iostat
+
+$(DL_DIR)/$(IOSTAT_SOURCE):
+ $(WGET) -P $(DL_DIR) $(IOSTAT_SITE)/$(IOSTAT_SOURCE)
+
+iostat-source: $(DL_DIR)/$(IOSTAT_SOURCE)
+
+$(IOSTAT_DIR)/.unpacked: $(DL_DIR)/$(IOSTAT_SOURCE)
+ zcat $(DL_DIR)/$(IOSTAT_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(IOSTAT_DIR) package/iostat/ iostat\*.patch
+ touch $(IOSTAT_DIR)/.unpacked
+
+$(IOSTAT_DIR)/$(IOSTAT_BINARY): $(IOSTAT_DIR)/.unpacked
+ $(MAKE) CC=$(TARGET_CC) -C $(IOSTAT_DIR)
+ $(STRIP) $(IOSTAT_DIR)/$(IOSTAT_BINARY)
+
+$(TARGET_DIR)/$(IOSTAT_TARGET_BINARY): $(IOSTAT_DIR)/$(IOSTAT_BINARY)
+ $(INSTALL) -m 0755 -D $(IOSTAT_DIR)/$(IOSTAT_BINARY) $(TARGET_DIR)/$(IOSTAT_TARGET_BINARY)
+
+iostat: uclibc $(TARGET_DIR)/$(IOSTAT_TARGET_BINARY)
+
+iostat-clean:
+ rm -f $(TARGET_DIR)/$(IOSTAT_TARGET_BINARY)
+ -$(MAKE) -C $(IOSTAT_DIR) clean
+
+iostat-dirclean:
+ rm -rf $(IOSTAT_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_IOSTAT)),y)
+TARGETS+=iostat
+endif
diff --git a/package/iostat/iostat.patch b/package/iostat/iostat.patch
new file mode 100644
index 000000000..acf2a52e4
--- /dev/null
+++ b/package/iostat/iostat.patch
@@ -0,0 +1,11 @@
+--- iostat-2.2/iostat.c.orig 2005-02-14 12:44:03.000000000 -0800
++++ iostat-2.2/iostat.c 2005-03-10 15:24:09.000000000 -0800
+@@ -140,7 +140,7 @@
+
+ handle_error("Can't open /proc/cpuinfo", !ncpufp);
+ while (fgets(buffer, sizeof(buffer), ncpufp)) {
+- if (!strncmp(buffer, "processor\t:", 11))
++ if (!strncmp(buffer, "processor\t", 10))
+ ncpu++;
+ }
+ fclose(ncpufp);