summaryrefslogtreecommitdiffstats
path: root/package/intltool/intltook.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-21 13:18:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-23 20:34:32 +0100
commit570e1b77c285be7b19d0be3dda27853b06b58ae8 (patch)
tree6c4d020702fe82164f9562a2d18a754fbb1dcb16 /package/intltool/intltook.mk
parent405a7ecaa19d229e144062a338d5a3b8cd21c96c (diff)
downloadbuildroot-novena-570e1b77c285be7b19d0be3dda27853b06b58ae8.tar.gz
buildroot-novena-570e1b77c285be7b19d0be3dda27853b06b58ae8.zip
intltool: new package
This XML internationalization set of tools is required to build several of our packages, and may not be available on the host machine. Only the host variant has been tested. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/intltool/intltook.mk')
-rw-r--r--package/intltool/intltook.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/intltool/intltook.mk b/package/intltool/intltook.mk
new file mode 100644
index 000000000..746ebb1d5
--- /dev/null
+++ b/package/intltool/intltook.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# intltool
+#
+#############################################################
+INTLTOOL_VERSION:=0.40.6
+INTLTOOL_SOURCE:=intltool-$(INTLTOOL_VERSION).tar.bz2
+INTLTOOL_SITE:=http://ftp.acc.umu.se/pub/GNOME/sources/intltool/0.40/
+
+HOST_INTLTOOL_DEPENDENCIES = host-libxml-parser-perl
+HOST_INTLTOOL_CONF_OPT = \
+ PERLLIB=$(HOST_DIR)/usr/lib/perl
+
+$(eval $(call AUTOTARGETS,package,intltool))
+$(eval $(call AUTOTARGETS,package,intltool,host))
+