summaryrefslogtreecommitdiffstats
path: root/package/imagemagick
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-21 13:39:35 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-23 20:34:34 +0100
commitb7ea597dd2f3553f2bc44e441011e68f999c7768 (patch)
tree15761e5d2674285c77e72f14ee9fabd89148a798 /package/imagemagick
parentcf04b9e0c5f7b55817999a5dd01d7ce740fd3d8e (diff)
downloadbuildroot-novena-b7ea597dd2f3553f2bc44e441011e68f999c7768.tar.gz
buildroot-novena-b7ea597dd2f3553f2bc44e441011e68f999c7768.zip
imagemagick: use internal libtool
For some reason, our imagemagick.mk file calls libtool, but assumes that libtool is available on the host, which may not be true. Therefore, we use ImageMagick's internal libtool, which has been used for compiling/linking all the rest of ImageMagic anyway. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/imagemagick')
-rw-r--r--package/imagemagick/imagemagick.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/imagemagick/imagemagick.mk b/package/imagemagick/imagemagick.mk
index e8584306e..00895f593 100644
--- a/package/imagemagick/imagemagick.mk
+++ b/package/imagemagick/imagemagick.mk
@@ -83,8 +83,8 @@ $(IMAGEMAGICK_LIB): $(STAGING_DIR)/usr/lib/libMagickCore.a
touch -c $@
$(IMAGEMAGICK_DIR)/.libinstall: $(IMAGEMAGICK_LIB)
- libtool --finish $(TARGET_DIR)/usr/lib/ImageMagick-$(IMAGEMAGICK_MAJOR)/modules-Q16/coders
- libtool --finish $(TARGET_DIR)/usr/lib/ImageMagick-$(IMAGEMAGICK_MAJOR)/modules-Q16/filters
+ $(IMAGEMAGICK_DIR)/libtool --finish $(TARGET_DIR)/usr/lib/ImageMagick-$(IMAGEMAGICK_MAJOR)/modules-Q16/coders
+ $(IMAGEMAGICK_DIR)/libtool --finish $(TARGET_DIR)/usr/lib/ImageMagick-$(IMAGEMAGICK_MAJOR)/modules-Q16/filters
touch $@
$(TARGET_DIR)/usr/bin/animate: $(IMAGEMAGICK_LIB)