summaryrefslogtreecommitdiffstats
path: root/package/ifplugd
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-10-15 00:07:34 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-15 23:21:45 +0200
commit16eb3ed2f1d498533157c11c4b4aabb719dcb9f5 (patch)
tree800b502f02369d13f4903363d36e143c0fc062d0 /package/ifplugd
parentb79ab02d462596566f8f2e2db518dad158bae5eb (diff)
downloadbuildroot-novena-16eb3ed2f1d498533157c11c4b4aabb719dcb9f5.tar.gz
buildroot-novena-16eb3ed2f1d498533157c11c4b4aabb719dcb9f5.zip
ifplugd: misc fixes
* Busybox provides ifplugd, so build after it and make the menu option conditional on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS * Style cleanup [Peter: really make it depend on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ifplugd')
-rw-r--r--package/ifplugd/ifplugd.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/package/ifplugd/ifplugd.mk b/package/ifplugd/ifplugd.mk
index 33c4367ee..cb06b6348 100644
--- a/package/ifplugd/ifplugd.mk
+++ b/package/ifplugd/ifplugd.mk
@@ -3,19 +3,20 @@
# ifplugd
#
#############################################################
+
IFPLUGD_VERSION = 0.28
-IFPLUGD_SOURCE = ifplugd-$(IFPLUGD_VERSION).tar.gz
-IFPLUGD_SITE = http://0pointer.de/lennart/projects/ifplugd/
+IFPLUGD_SITE = http://0pointer.de/lennart/projects/ifplugd
IFPLUGD_AUTORECONF = YES
-IFPLUGD_INSTALL_STAGING = NO
-IFPLUGD_INSTALL_TARGET = YES
# install-strip unconditionally overwrites $(TARGET_DIR)/etc/ifplugd/ifplugd.*
IFPLUGD_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-exec
-
IFPLUGD_CONF_OPT = --disable-lynx
-
IFPLUGD_DEPENDENCIES = libdaemon
+# Prefer big ifplugd
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+ IFPLUGD_DEPENDENCIES += busybox
+endif
+
define IFPLUGD_INSTALL_FIXUP
$(INSTALL) -d $(TARGET_DIR)/etc/ifplugd
@if [ ! -f $(TARGET_DIR)/etc/ifplugd/ifplugd.conf ]; then \