summaryrefslogtreecommitdiffstats
path: root/package/ifplugd
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-12-13 19:40:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-12-13 19:40:26 +0000
commit060dca08f9d90d78415dd1a7ce693e92d66f0d6b (patch)
tree4ea967f49ecaf92e61010fbd385c7c0a991924f5 /package/ifplugd
parent978d8dc53e997203c7244c9cb599247c68e1c72e (diff)
downloadbuildroot-novena-060dca08f9d90d78415dd1a7ce693e92d66f0d6b.tar.gz
buildroot-novena-060dca08f9d90d78415dd1a7ce693e92d66f0d6b.zip
ifplugd: fix non-C++ build
The ifplugd configure script was checking for a C++ compiler, even though it isn't used for anything.
Diffstat (limited to 'package/ifplugd')
-rw-r--r--package/ifplugd/ifplugd-no-cxx.patch17
-rw-r--r--package/ifplugd/ifplugd.mk2
2 files changed, 18 insertions, 1 deletions
diff --git a/package/ifplugd/ifplugd-no-cxx.patch b/package/ifplugd/ifplugd-no-cxx.patch
new file mode 100644
index 000000000..50ec0545a
--- /dev/null
+++ b/package/ifplugd/ifplugd-no-cxx.patch
@@ -0,0 +1,17 @@
+[PATCH] ifplugd: configure: don't check for C++ compiler
+
+The configure script was checking for a C++ compiler (and erroring out
+if not found), even though it isn't used for anything.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+diff -urpN ifplugd-0.28/configure.ac ifplugd-0.28.new/configure.ac
+--- ifplugd-0.28/configure.ac 2005-06-04 21:21:51.000000000 +0200
++++ ifplugd-0.28.new/configure.ac 2008-12-13 20:31:13.000000000 +0100
+@@ -33,7 +33,6 @@ if type -p stow > /dev/null && test -d /
+ fi
+
+ # Checks for programs.
+-AC_PROG_CXX
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_INSTALL
diff --git a/package/ifplugd/ifplugd.mk b/package/ifplugd/ifplugd.mk
index 763eabc79..3d0b844cc 100644
--- a/package/ifplugd/ifplugd.mk
+++ b/package/ifplugd/ifplugd.mk
@@ -6,7 +6,7 @@
IFPLUGD_VERSION = 0.28
IFPLUGD_SOURCE = ifplugd-$(IFPLUGD_VERSION).tar.gz
IFPLUGD_SITE = http://0pointer.de/lennart/projects/ifplugd/
-IFPLUGD_AUTORECONF = NO
+IFPLUGD_AUTORECONF = YES
IFPLUGD_INSTALL_STAGING = NO
IFPLUGD_INSTALL_TARGET = YES
# install-strip unconditionally overwrites $(TARGET_DIR)/etc/ifplugd/ifplugd.*