summaryrefslogtreecommitdiffstats
path: root/package/hwdata
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-01-14 03:38:02 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-01-14 03:38:02 +0000
commit8d08091cf8684110fe191e63f3c4167298d19096 (patch)
tree28f6b733c88ade5a225cc87cb0149bc38974845f /package/hwdata
parentea18cf815ce7a5012129d719b126bcea9cf37ddf (diff)
downloadbuildroot-novena-8d08091cf8684110fe191e63f3c4167298d19096.tar.gz
buildroot-novena-8d08091cf8684110fe191e63f3c4167298d19096.zip
Add new 'hwdata' package which we will need for D-Bus and HAL.
Diffstat (limited to 'package/hwdata')
-rw-r--r--package/hwdata/Config.in6
-rw-r--r--package/hwdata/hwdata.mk50
2 files changed, 56 insertions, 0 deletions
diff --git a/package/hwdata/Config.in b/package/hwdata/Config.in
new file mode 100644
index 000000000..2f6fd0545
--- /dev/null
+++ b/package/hwdata/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_HWDATA
+ bool "hwdata"
+ default n
+ help
+ Various hardware identification and configuration data, such as
+ the pci.ids database, or the XFree86/xorg Cards database.
diff --git a/package/hwdata/hwdata.mk b/package/hwdata/hwdata.mk
new file mode 100644
index 000000000..133b37a36
--- /dev/null
+++ b/package/hwdata/hwdata.mk
@@ -0,0 +1,50 @@
+#############################################################
+#
+# hwdata
+#
+#############################################################
+HWDATA_VERSION:=0.191
+HWDATA_SOURCE:=hwdata_$(HWDATA_VERSION).orig.tar.gz
+HWDATA_PATCH:=hwdata_$(HWDATA_VERSION)-1.diff.gz
+HWDATA_SITE:=http://ftp.debian.org/debian/pool/main/h/hwdata/
+HWDATA_CAT:=$(ZCAT)
+HWDATA_DIR:=$(BUILD_DIR)/hwdata-$(HWDATA_VERSION)
+HWDATA_BINARY:=pci.ids
+HWDATA_TARGET_BINARY:=usr/share/hwdata/pci.ids
+
+$(DL_DIR)/$(HWDATA_SOURCE):
+ $(WGET) -P $(DL_DIR) $(HWDATA_SITE)/$(HWDATA_SOURCE)
+
+$(DL_DIR)/$(HWDATA_PATCH):
+ $(WGET) -P $(DL_DIR) $(HWDATA_SITE)/$(HWDATA_PATCH)
+
+hwdata-source: $(DL_DIR)/$(HWDATA_SOURCE) $(DL_DIR)/$(HWDATA_PATCH)
+
+$(HWDATA_DIR)/.unpacked: $(DL_DIR)/$(HWDATA_SOURCE) $(DL_DIR)/$(HWDATA_PATCH)
+ $(HWDATA_CAT) $(DL_DIR)/$(HWDATA_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(HWDATA_DIR) $(DL_DIR) $(HWDATA_PATCH)
+ touch $(HWDATA_DIR)/.unpacked
+
+$(TARGET_DIR)/$(HWDATA_TARGET_BINARY): $(HWDATA_DIR)/.unpacked
+ mkdir -p -m 755 $(TARGET_DIR)/usr/share/hwdata
+ cp -a $(HWDATA_DIR)/pci.ids $(TARGET_DIR)/usr/share/hwdata
+ cp -a $(HWDATA_DIR)/usb.ids $(TARGET_DIR)/usr/share/hwdata
+ -touch -c $(TARGET_DIR)/usr/share/hwdata/*
+
+hwdata: uclibc $(TARGET_DIR)/$(HWDATA_TARGET_BINARY)
+
+hwdata-clean:
+ rm -rf $(TARGET_DIR)/usr/share/hwdata
+ rmdir --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
+
+hwdata-dirclean:
+ rm -rf $(HWDATA_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_HWDATA)),y)
+TARGETS+=hwdata
+endif