summaryrefslogtreecommitdiffstats
path: root/package/httping/httping.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-01-20 21:12:11 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-20 21:17:49 +0100
commitd9cbc45b92d760c1c7651ae48bf8d29e55533e32 (patch)
tree46271deea805f442f9dc489420134a113f7fc101 /package/httping/httping.mk
parent4d93ca15bce45484305136fd4cd46d52b398b8b8 (diff)
downloadbuildroot-novena-d9cbc45b92d760c1c7651ae48bf8d29e55533e32.tar.gz
buildroot-novena-d9cbc45b92d760c1c7651ae48bf8d29e55533e32.zip
httping: don't override optimization level, correctly disable debug support
The httping makefile by default appends -O3 to CFLAGS, overriding the optimization flags set in Buildroot, so pass OFLAGS= to disable this. The DEBUG=no argument has to be passed on the make cmdline and not in the environment to take effect, as it is unconditionally set in the Makefile. Notice that it shouldn't be passed to 'make install', as that otherwise will try to run the host strip program. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/httping/httping.mk')
-rw-r--r--package/httping/httping.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/httping/httping.mk b/package/httping/httping.mk
index 45478cfdc..e92be619a 100644
--- a/package/httping/httping.mk
+++ b/package/httping/httping.mk
@@ -12,11 +12,10 @@ HTTPING_LICENSE_FILES = license.txt
HTTPING_DEPENDENCIES = $(if $(BR2_PACKAGE_OPENSSL),openssl)
HTTPING_MAKE_OPT = $(TARGET_CONFIGURE_OPTS) \
SSL=$(if $(BR2_PACKAGE_OPENSSL),yes,no) \
- TFO=$(if $(BR2_PACKAGE_HTTPING_TFO),yes,no) \
- DEBUG=no
+ TFO=$(if $(BR2_PACKAGE_HTTPING_TFO),yes,no)
define HTTPING_BUILD_CMDS
- $(HTTPING_MAKE_OPT) $(MAKE) -C $(@D)
+ $(HTTPING_MAKE_OPT) $(MAKE) OFLAGS= DEBUG=no -C $(@D)
endef
define HTTPING_INSTALL_TARGET_CMDS