summaryrefslogtreecommitdiffstats
path: root/package/httping/httping.mk
diff options
context:
space:
mode:
authorGilles Talis <gilles.talis@gmail.com>2013-01-14 13:32:07 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-15 09:22:43 +0100
commit96f6054ccd7edc9add815d44720563c998eca088 (patch)
treec020484da3fc707b5aa63878ae57e00457054b8a /package/httping/httping.mk
parentd3222862f62ebe80c0cb4b680e6fb46c03cc5706 (diff)
downloadbuildroot-novena-96f6054ccd7edc9add815d44720563c998eca088.tar.gz
buildroot-novena-96f6054ccd7edc9add815d44720563c998eca088.zip
httping: new package
Httping is like 'ping' but for http-requests. Give it an url, and it'll show you how long it takes to connect, send a request and retrieve the reply (only the headers) [Peter: Drop ssl option, use make install, misc cleanup] Signed-off-by: Gilles Talis <gilles.talis@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/httping/httping.mk')
-rw-r--r--package/httping/httping.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/httping/httping.mk b/package/httping/httping.mk
new file mode 100644
index 000000000..3ec1dae4f
--- /dev/null
+++ b/package/httping/httping.mk
@@ -0,0 +1,29 @@
+#############################################################
+#
+# httping
+#
+#############################################################
+
+HTTPING_VERSION = 1.5.7
+HTTPING_SOURCE = httping-$(HTTPING_VERSION).tgz
+HTTPING_SITE = http://www.vanheusden.com/httping
+HTTPING_LICENSE = GPLv2
+HTTPING_LICENSE_FILES = license.txt
+HTTPING_DEPENDENCIES = $(if $(BR2_PACKAGE_OPENSSL),openssl)
+
+define HTTPING_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+ SSL=$(if $(BR2_PACKAGE_OPENSSL),yes,no) \
+ TFO=$(if $(BR2_PACKAGE_HTTPING_TFO),yes,no) \
+ DEBUG=no -C $(@D)
+endef
+
+define HTTPING_INSTALL_TARGET_CMDS
+ $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+define HTTPING_CLEAN_CMDS
+ $(MAKE) -C $(@D) clean
+endef
+
+$(eval $(generic-package))