summaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-12-28 09:47:18 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-28 21:53:54 +0100
commit788fcd99e0578e361f192aae4b89b15f1a60faac (patch)
tree2268320f46ab9e7aea34e3f1edc78fc13f1f9b42 /package/hostapd
parentac4e3c02d43708ed1263186b52a791c615d67cce (diff)
downloadbuildroot-novena-788fcd99e0578e361f192aae4b89b15f1a60faac.tar.gz
buildroot-novena-788fcd99e0578e361f192aae4b89b15f1a60faac.zip
hostapd: remove gnutls support
hostapd isn't API compatible with gnutls3 so remove support. It's probably hardly used since openssl is far more common, and hostapd can use its internal routines if it's not available. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/hostapd.mk9
1 files changed, 1 insertions, 8 deletions
diff --git a/package/hostapd/hostapd.mk b/package/hostapd/hostapd.mk
index 45a93fc7b..b18881ad8 100644
--- a/package/hostapd/hostapd.mk
+++ b/package/hostapd/hostapd.mk
@@ -27,7 +27,7 @@ define HOSTAPD_LIBTOMMATH_CONFIG
$(SED) 's/\(#\)\(CONFIG_INTERNAL_LIBTOMMATH.*\)/\2/' $(HOSTAPD_CONFIG)
endef
-# Try to use openssl or gnutls if it's already available
+# Try to use openssl if it's already available
ifeq ($(BR2_PACKAGE_OPENSSL),y)
HOSTAPD_DEPENDENCIES += openssl
define HOSTAPD_TLS_CONFIG
@@ -35,17 +35,10 @@ define HOSTAPD_TLS_CONFIG
$(SED) 's/\(#\)\(CONFIG_EAP_PWD.*\)/\2/' $(HOSTAPD_CONFIG)
endef
else
-ifeq ($(BR2_PACKAGE_GNUTLS),y)
- HOSTAPD_DEPENDENCIES += gnutls
-define HOSTAPD_TLS_CONFIG
- $(SED) 's/\(#\)\(CONFIG_TLS=\).*/\2gnutls/' $(HOSTAPD_CONFIG)
-endef
-else
define HOSTAPD_TLS_CONFIG
$(SED) 's/\(#\)\(CONFIG_TLS=\).*/\2internal/' $(HOSTAPD_CONFIG)
endef
endif
-endif
ifeq ($(BR2_PACKAGE_HOSTAPD_EAP),y)
define HOSTAPD_EAP_CONFIG